Download it now!
Bug 89376 - Some lines in EMF files don't render
Summary: Some lines in EMF files don't render
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: x86 (IA32) Mac OS X (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-14 16:16 UTC by Andrew Watson
Modified: 2018-02-09 16:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ZIP archive of incorrectly-rendered NotationDependency.emf and derived graphics showing symptoms (152.43 KB, application/zip)
2015-02-14 16:16 UTC, Andrew Watson
Details
Zip archive of PDF and PNG graphics showing behaviour under LO 5.4.1.2 (165.80 KB, application/zip)
2017-09-15 20:58 UTC, Andrew Watson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Watson 2015-02-14 16:16:08 UTC
Created attachment 113379 [details]
ZIP archive of incorrectly-rendered NotationDependency.emf and derived graphics showing symptoms

None of the lines in the attached simple EMF file render when the file is included in a LO Writer document via Insert->Picture->From File. All the text appears on screen, but then none of the EMF content (text or lines) appears when file is exported as PDF.

Problem found in LO 4.0.6.2 running under Mac OS 10.5.8, also reproduced on LO 4.4.1.1 running under MacOS 10.9.x

Attached ZIP archive contains:

NotationDependency.emf                     -- EMF file that provokes the problem
NotationDependency_saved_from_Inkscape.pdf -- PDF saved from Inkscape showing how it should look
NotationDependency_in_Writer.odt           -- Saved LO file that displays text but no lines on screen
NotationDependency_in_Writer.pdf           -- PDF file exported from LO that contains neither text nor lines
NotationDependency_in_Writer_screen_shot.tiff  -- Screen shot of LO 4.0.6.2 under Mac OS 10.5.8 showing text but not lines displaying
Comment 1 Andrew Watson 2015-02-14 16:30:09 UTC
On further investigation, this may be a duplicate of Bug 31814 (https://bugs.documentfoundation.org//show_bug.cgi?id=31814) - I downloaded one of the EMF files from the middle of that bug's thread, and the symptoms look identical.
Comment 2 Robinson Tryon (qubit) 2015-02-19 00:42:07 UTC
(In reply to Andrew Watson from comment #1)
> On further investigation, this may be a duplicate of Bug 31814
> (https://bugs.documentfoundation.org//show_bug.cgi?id=31814) - I downloaded
> one of the EMF files from the middle of that bug's thread, and the symptoms
> look identical.

Let's mark it as a dupe for now. You can always open a new bug if the resolution of that bug doesn't fix all of your problems!

*** This bug has been marked as a duplicate of bug 31814 ***
Comment 3 Timur 2017-08-24 18:05:41 UTC
Doesn't really look like a dupe of Bug 31814 or some of those solved in 5.4.
Looked fine in Windows until recently, but that's another bug.
So I'll set back to Needinfo.
Andrew, please check with recent LO version.
Comment 4 Andrew Watson 2017-09-15 20:31:03 UTC
I downloadaded the attachment ZIP and re-checked behaviour when opening with LO 5.4.1.2 (build ID ea7cb86e6eeb2bf3a5af73a8f7777ac570321527) under MacOS 10.11.6.
Comment 5 Andrew Watson 2017-09-15 20:58:16 UTC
Created attachment 136273 [details]
Zip archive of PDF and PNG graphics showing behaviour under LO 5.4.1.2

Zip archive of PDF and PNG graphics showing behaviour under LO 5.4.1.2. Filed 2017-09-15.
Comment 6 Andrew Watson 2017-09-15 21:01:11 UTC
(Apologies for duplicated comments - finger trouble)

I downloadaded the original attachment ZIP and re-checked behaviour when opening NotationDependency_in_Writer.odt with LO 5.4.1.2 (build ID ea7cb86e6eeb2bf3a5af73a8f7777ac570321527) under MacOS 10.11.6.

The Good News: the PDF exported using File>Export As PDF ... now looks broadly correct (as compared to NotationDependency_saved_from_Inkscape.pdf, which shows what a recent Inkscape version shows).

The OK-ish news: LO's screen display now also looks reasonable when screen magnification is set to greater than about 105% using View>Zoom. Not perfect, however - there are character spacing problems in the labels. However, all the text and lines are there.

The Bad News: when screen magnification is set to 100% or less using View>Zoom then the on-screen display still lacks some lines.

So there's atill a bug (although it's changed characted somewhat).

See LO_EMFbug_report_2017-09-15.zip for screen shots and exported PDF.
Comment 7 Martin Srebotnjak 2018-02-08 10:39:40 UTC
Andrew, could you try this with LO6, if it still persists?
Comment 8 Andrew Watson 2018-02-09 14:41:06 UTC
I downloadaded the original attachment ZIP and re-checked behaviour when opening NotationDependency_in_Writer.odt with LO 6.0.1.1 (build ID 60bfb1526849283ce2491346ed2aa51c465abfe6) under MacOS 10.11.6.

Good news - both the exported PDF and the screen display at all zoom levels now look good.

I also re-imported the NotationDependency.emf into a nre graphics document under LO 6.0.1.1 - also worked as expected.

IMHO this bug report can be closed as RESOLVED (but I changed the status to "UNCONFIRMED" as per "Note to Bug Reporter".

Many thanks!
Comment 9 Timur 2018-02-09 16:29:46 UTC
It's WorksForMe becaus ewe don't know the exact commit. 
Thank you for your testing.  
It's always a good idea to test with https://dev-builds.libreoffice.org/daily/master/.