Bug 89378 - FORMATTING: Paste options
Summary: FORMATTING: Paste options
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 101818 (view as bug list)
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2015-02-14 17:46 UTC by Victor Krymskiy
Modified: 2019-08-31 10:28 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Paste options (4.87 KB, image/png)
2015-02-14 17:46 UTC, Victor Krymskiy
Details
New attachment (9.07 KB, image/png)
2015-02-22 22:41 UTC, Victor Krymskiy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Krymskiy 2015-02-14 17:46:29 UTC
Created attachment 113384 [details]
Paste options

Dear all,

Please, implement "Paste options" button as it is in MS Office (see picture).

When you paste the text it would be very helpfull to have options to choose which format to apply.

It would be very helpfull to see this button in all LO applications (at least in Writer and Calc).
Comment 1 Buovjaga 2015-02-22 13:10:56 UTC
Handing over to the design team and purposefully leaving this UNCONFIRMED as the team might not agree with the reporter.
Comment 2 m.a.riosv 2015-02-22 16:20:15 UTC
Clicking the right arrow of paste button, shows the options on how to paste.
Comment 3 Victor Krymskiy 2015-02-22 17:40:11 UTC
Yes, but not as easy as it is in MS Office.
Comment 4 m.a.riosv 2015-02-22 22:22:38 UTC
Please what is it not so easy?, there are two clicks on both.
Comment 5 Victor Krymskiy 2015-02-22 22:41:24 UTC
Created attachment 113611 [details]
New attachment
Comment 6 Victor Krymskiy 2015-02-22 22:44:47 UTC
See attached example. 

There is very often when you do not know which format it is better to apply.

In LO you have to copy-paste it again and again clicking 2 times untill you find the solution. And it will be 3 times clicks after the second copy-paste (the system will ask you if you are sure to replace the cell). In MS Office it is just 1 click.

It is necessary to simplify the process.
Comment 7 Robinson Tryon (qubit) 2015-02-25 21:39:47 UTC Comment hidden (obsolete)
Comment 8 Yousuf Philips (jay) (retired) 2015-02-27 11:15:53 UTC
With 4.4, we have paste and paste unformatted text in Writer, and i've filled a bug report about implement third option found in Word and WordPerfect (bug 83102).

With Calc, the context menu has paste Text, Number, and Formula under the paste only submenu. Paste unformatted text needs to be implemented there as well.
Comment 9 Robinson Tryon (qubit) 2016-08-25 04:44:56 UTC Comment hidden (obsolete)
Comment 10 Heiko Tietze 2018-01-11 10:16:47 UTC
How to get rid of this paste option box is a frequently asked question for Microsoft Office. Calc shows you a dialog on shift+ctrl+v (or Edit > Paste Special...) that has more features than competitors and works perfectly. 

Let's keep it boring but established.
Comment 11 Heiko Tietze 2018-01-12 09:52:24 UTC
*** Bug 101818 has been marked as a duplicate of this bug. ***