Bug 89447 - Android: Use SVG icon for SVG files
Summary: Android: Use SVG icon for SVG files
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2015-02-17 22:26 UTC by Robinson Tryon (qubit)
Modified: 2021-04-07 07:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot for "Recent files" with ODP and SVG file (55.86 KB, image/png)
2021-04-07 07:29 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robinson Tryon (qubit) 2015-02-17 22:26:57 UTC
Testing with Version 4.5.0.0.alpha0+/3f1713b - Added on 2015-02-14 (From F-droid).

When browsing files in a directory, SVG files are represented with a presentation icon (the same as ODP files). These files should have a separate icon that represents vector graphics/SVG specifically. The use of the presentation icon is confusing.
Comment 1 tommy27 2016-04-16 07:23:25 UTC Comment hidden (obsolete)
Comment 2 Robinson Tryon (qubit) 2016-08-18 20:39:01 UTC
TESTING with 5.3.0.0.alpha0+ (Build ID: f2da317)

(In reply to Robinson Tryon (qubit) from comment #0)
> When browsing files in a directory, SVG files are represented with a
> presentation icon (the same as ODP files). These files should have a
> separate icon that represents vector graphics/SVG specifically. The use of
> the presentation icon is confusing.

Test image: 
https://openclipart.org/detail/258803/draw-piggie

The problem persists in 5.3.x builds
Comment 3 QA Administrators 2017-09-01 11:16:18 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2020-12-16 03:57:47 UTC Comment hidden (obsolete)
Comment 5 Michael Weghorn 2021-04-07 07:29:42 UTC
Created attachment 170990 [details]
Screenshot for "Recent files" with ODP and SVG file
Comment 6 Michael Weghorn 2021-04-07 07:33:12 UTC
attachment 170990 [details] shows a screenshot with current git master as of commit 53d1c08f1a77910ff7982cb2b68b8f1a1ed102c9.

* For SVG files in the "Recently files" list, the same Draw icon as for an ODG file is shown, i.e. no more the same as for a presentation, as the initial comment says. This is reasonable IMHO, since it is a graphics file handled by Draw, not Impress.

* For browsing and opening files from within LO Viewer, Android's system file picker is used now, so the icons that the system chooses are shown, this is no more under LO control. It shows a (different) graphics icon as well, which seems to be OK.

-> closing as WORKSFORME