Bug 89449 - Line connectors become shape objects in Impress when opening Microsoft .PPTX file format
Summary: Line connectors become shape objects in Impress when opening Microsoft .PPTX ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, filter:pptx, regression
: 80236 105398 (view as bug list)
Depends on:
Blocks: Connectors PPTX-Shapes
  Show dependency treegraph
 
Reported: 2015-02-18 01:29 UTC by gadgetpig
Modified: 2022-06-28 10:12 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
line shape bug screenshot (66.15 KB, image/png)
2015-02-18 01:29 UTC, gadgetpig
Details
connector line working as normal connector (46.35 KB, image/png)
2015-02-19 16:24 UTC, gadgetpig
Details
connector line is now a line shape. loses connector properties (123.15 KB, image/png)
2015-02-19 16:25 UTC, gadgetpig
Details
sample pptx file (115.02 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-02-19 16:25 UTC, gadgetpig
Details
impress document where line connector becomes line shape (238.93 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-02-19 16:32 UTC, gadgetpig
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gadgetpig 2015-02-18 01:29:04 UTC
Created attachment 113478 [details]
line shape bug screenshot

When opening a PPTX file with shapes connected by "line connectors" originally saved in Powerpoint 2013, the lines become "objects" instead of line connectors in Libreoffice.  

Without saving changes and opening the same PPTX file in Powerpoint 2013/powerpoint online, the lines become normal connectors again.
Comment 1 Robinson Tryon (qubit) 2015-02-19 01:00:30 UTC
(In reply to gadgetpig from comment #0)
> Created attachment 113478 [details]
> line shape bug screenshot
> 
> When opening a PPTX file with shapes connected by "line connectors"
> originally saved in Powerpoint 2013, the lines become "objects" instead of
> line connectors in Libreoffice.  
> 
> Without saving changes and opening the same PPTX file in Powerpoint
> 2013/powerpoint online, the lines become normal connectors again.

Hiya,

Please attach
1) The original PPTX file
2) A screenshot of how the document should look in PowerPoint
3) (OPTIONALLY) a screenshot of how the document looks in Impress

Status -> NEEDINFO

(Please change status back to UNCONFIRMED after you attach the files)
Comment 2 gadgetpig 2015-02-19 16:24:14 UTC
Created attachment 113504 [details]
connector line working as normal connector
Comment 3 gadgetpig 2015-02-19 16:25:06 UTC
Created attachment 113505 [details]
connector line is now a line shape. loses connector properties
Comment 4 gadgetpig 2015-02-19 16:25:52 UTC
Created attachment 113506 [details]
sample pptx file
Comment 5 gadgetpig 2015-02-19 16:32:22 UTC
Created attachment 113507 [details]
impress document where line connector becomes line shape
Comment 6 gadgetpig 2015-02-19 16:36:24 UTC
to recreate issue:

-create impress document
-copy 2 picture objects from internet and paste into impress document
-create line connector and attach to both picture objects
-save document
-reopen document and line connector loses it's properties and becomes line shape instead
Comment 7 Robinson Tryon (qubit) 2015-02-19 22:21:18 UTC
(In reply to gadgetpig from comment #5)
> Created attachment 113507 [details]
> impress document where line connector becomes line shape

Hi Gadgetpig,

Thanks for the test files and repro steps. I noticed one strange thing, which is that said attachment ("libreoffice test from scratch.pptx") has a listed MIMEtype of application/zip, although when I do unzip it I find the guts of what looks like a PPTX file.

I'm not sure if this has any bearing on the problems you're seeing, but I wanted to point it out. (It's possible this is a problem on our end, with Bugzilla)

Status back to UNCONFIRMED.
Comment 8 Buovjaga 2015-02-25 09:17:47 UTC
Confirmed with attachment 113506 [details].

Works ok in 3.3.0, but already broken in 3.5.0, so not bibisectable.

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: fi_FI

Version: 4.5.0.0.alpha0+
Build ID: b13534de022972131b46f93f5ada90af155eec9e
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-02-19_00:21:37
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.4.0.3
Build ID: 40m0(Build:3)
Locale: en_US

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 9 gadgetpig 2015-02-25 18:43:30 UTC
Just changed the bug summary text.  The issue happens only when opening/saving as Microsoft PowerPoint .pptx file format.  Issue does not happen when saving in native .ODP format, or older Microsoft .ppt binary format.  I guess it's somewhere in the LibreOffice Microsoft XML conversion module?

thanks
Comment 10 Robinson Tryon (qubit) 2015-03-05 16:43:37 UTC
(In reply to Beluga from comment #8)
> Works ok in 3.3.0, but already broken in 3.5.0, so not bibisectable.

Whiteboard -> notBibisectable
Comment 11 gadgetpig 2015-03-06 02:38:05 UTC
Modified summary.  More info on this issue.  It seems the connector info is saved properly with the impress document.  Because when I open it with PowerPoint web app, the connector shows properly.  It's only when you open .PPTX file with Impress do the connectors become shape objects.  I modified the summary to reflect this.  So the issue seems to be the Impress .PPTX document filter is not opening/decoding the connector attributes properly.  When Impress opens .PPTX files, it thinks the line connectors are shapes.
Comment 12 gadgetpig 2015-03-17 22:28:39 UTC
Modified bug summary text.  Also confirmed issue occurs in release candidate:

Version: 4.4.2.1
Build ID: 93fc8832889bf050a10ec6d0171dae213adc9b55
Locale: en_US
Comment 13 gadgetpig 2015-04-19 11:45:20 UTC
Confirmed issue persists with 4.4.3.1 nightly:

Version: 4.4.3.1
Build ID: b2f347f2ac68821efc00b6f1793cda90af748118
Locale: en_U
Comment 14 gadgetpig 2015-07-20 03:16:51 UTC
Confirmed issue still persists with LibreOffice stable 4.4.4.3:

Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Locale: en_US
Comment 15 Robinson Tryon (qubit) 2015-12-10 01:26:43 UTC Comment hidden (obsolete)
Comment 16 gadgetpig 2016-03-11 14:48:15 UTC
Issue persist/became worse as of Version: 5.1.1.3 (x64)
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d

To recreate, create new impress document insert 2 smiley face and connector between them, save as .pptx file. Re-opening, the connector is completely missing.  Normally the previous bug was the connector would turn into a large shape object instead of connector object.
Comment 17 Xisco Faulí 2016-09-14 22:14:51 UTC
Replacing keyword 'notBibisectable' by 'preBibisect' as this bug is outside the bibisect range
Comment 18 gadgetpig 2017-09-20 21:47:30 UTC
Issue still exists with LibreOffice 4.1.2

Version: 5.4.1.2 (x64)
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
Comment 19 gadgetpig 2017-10-23 23:59:56 UTC
Issue still persists with:
Version: 5.4.2.2 (x64)
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 20 QA Administrators 2018-10-25 03:03:05 UTC Comment hidden (obsolete)
Comment 21 Regina Henschel 2019-05-08 21:48:33 UTC
The problem still exists in Version: 6.3.0.0.alpha0+ (x64)
Build ID: 15c39bb2e75df40c30bcbf789d815376dd2e31ce
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-02_22:43:22
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded

The "straightConnector1" becomes a simple custom shape on import.
Comment 22 Regina Henschel 2019-05-08 22:34:30 UTC
Look at https://opengrok.libreoffice.org/xref/core/oox/source/drawingml/connectorshapecontext.cxx?r=85fe083c#54

It seems, that nothing is implemented for import of connector shapes.
Comment 23 NISZ LibreOffice Team 2021-01-14 10:17:48 UTC
*** Bug 105398 has been marked as a duplicate of this bug. ***
Comment 24 Aron Budea 2021-03-04 00:19:44 UTC
(In reply to Xisco Faulí from comment #17)
> Replacing keyword 'notBibisectable' by 'preBibisect' as this bug is outside
> the bibisect range
This could actually be bibisected using bibisect-43all, to the following range:
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=10f977981d2cfb6ba0ccd0185ccb12e212010bc2..558b5ea32a99654dcb63526f107726f7aec4747f

Of which the following commit stands out:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=30b052e7b65434d2a78ab36d8f4475abe0c86a2a
author		Muthu Subramanian <sumuthu@suse.com>	2011-12-02 22:48:27 +0530
committer	Muthu Subramanian <sumuthu@suse.com>	2011-12-02 22:48:27 +0530

n#719989/97: Connector shape fixes.
Comment 25 Commit Notification 2022-03-29 14:13:26 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cbf66ec3e60d07efb7c3cceed9b4f0fb4f0510c8

tdf#89449 PPTX import: fix line connectors

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 László Németh 2022-03-29 14:17:56 UTC
Fixed in https://cgit.freedesktop.org/libreoffice/core/commit/?id=cbf66ec3e60d07efb7c3cceed9b4f0fb4f0510c8

@Regina: thanks for the code pointer!

@Tibor: thanks for the fix!

@Áron: I wasn't sure, that this was implemented for PPTX originally, so I didn't write about it in the commit description.

@Gadgetpig: thanks for reporting the problem!
Comment 27 NISZ LibreOffice Team 2022-03-31 08:51:13 UTC
Verified in:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a3988b2d147a2442b348d58b79dbd6e71472b7af
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: threaded
Comment 28 Gabor Kelemen (allotropia) 2022-05-01 18:25:40 UTC
*** Bug 80236 has been marked as a duplicate of this bug. ***