Bug 89478 - ODF import: page style background image lost if page style has both fo:background-color and style:background-image
Summary: ODF import: page style background image lost if page style has both fo:backgr...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: odf target:5.0.0 target:4.4.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-02-19 18:38 UTC by Gabriele Ponzo
Modified: 2015-12-17 08:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test File (44.49 KB, application/vnd.oasis.opendocument.text)
2015-02-19 18:38 UTC, Gabriele Ponzo
Details
This is how the test file is shown by LibO 3.6.7.2 (130.23 KB, image/png)
2015-02-19 18:41 UTC, Gabriele Ponzo
Details
This is how the test file is shown by LibO 4.4.1.1rc1 (119.03 KB, image/png)
2015-02-19 18:42 UTC, Gabriele Ponzo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Ponzo 2015-02-19 18:38:47 UTC
Created attachment 113516 [details]
Test File

Opening my invoices template AND edited files I just can't see the background image any longer. It has never happened before with any version.

I'm using MacOs X 10.8.5 and it fails on 4.4.1.1 rc1 as well.

I'm attaching some files for demo.

I've tried creating a new file on 3.6.7.2 (just because it's may second LibO installed version just for those issues :) and putting a background image and then opening this file with 4.4.1.1 rc1: IT DOESN'T HAPPEN!

So it must be something particular inside my own (template and) files, but I've never had issues with them in last 10 years or so.
Comment 1 Gabriele Ponzo 2015-02-19 18:41:26 UTC
Created attachment 113517 [details]
This is how the test file is shown by LibO 3.6.7.2
Comment 2 Gabriele Ponzo 2015-02-19 18:42:03 UTC
Created attachment 113518 [details]
This is how the test file is shown by LibO 4.4.1.1rc1
Comment 3 raal 2015-02-24 19:58:19 UTC
I can see background image with LO 3.5, but can not see with Version: 4.5.0.0.alpha0+
Build ID: a2fa9e2468aa5c4fd4b610c5d0ebc8959e87a072
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-02-23_02:34:05

Setting as NEW
Comment 4 V Stuart Foote 2015-03-04 16:34:08 UTC

*** This bug has been marked as a duplicate of bug 86578 ***
Comment 5 Michael Stahl (CIB) 2015-04-14 15:44:06 UTC
regression from commit 7d9bb549d498d6beed2c4050c402d09643febdfa

this is not a duplicate of bug 86578

fixed on master
Comment 6 Michael Stahl (CIB) 2015-04-14 16:11:10 UTC
bot is AWOL again, adding manually:

fixed on master by commit b82791e3c586d6e4247d0eb1bb94681bcb113762
Comment 7 Commit Notification 2015-04-14 16:23:09 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b82791e3c586d6e4247d0eb1bb94681bcb113762

tdf#89478: svx: ODF import: SvxBrushItem Graphics should override Color

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-04-14 16:28:27 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b82791e3c586d6e4247d0eb1bb94681bcb113762

tdf#89478: svx: ODF import: SvxBrushItem Graphics should override Color

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-04-14 20:06:26 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ac8be3d609a219c62713d37d22f8fef0115809f1&h=libreoffice-4-4

tdf#89478: svx: ODF import: SvxBrushItem Graphics should override Color

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-04-16 21:10:13 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fa4fb5b45b72ff66659606040ce3ad89609d526f

tdf#89478: svx: ODF import: SvxBrushItem Graphics should override Color

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Robinson Tryon (qubit) 2015-12-17 08:46:51 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]