Bug 89486 - The decimal separator key should always produce a period character in Writer
Summary: The decimal separator key should always produce a period character in Writer
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Decimal-Separator-Key
  Show dependency treegraph
 
Reported: 2015-02-19 23:41 UTC by Thomas Bertels
Modified: 2017-10-27 09:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Bertels 2015-02-19 23:41:27 UTC
The keyboard decimal separator key . (between 0 and Enter on the numeric keypad) produces a period '.' or a comma "," depending on the OS regional settings .

However, in Writer, it should always produce a period regardless of the OS regional settings and in accordance to what the keyboard shows.
This is the behavior of Microsoft Word if it matters.

It may be made an option set to that behavior by default.
Comment 1 Buovjaga 2015-02-25 09:24:01 UTC
Yep, I get a comma with Finnish and a period with Eng. USA locale.

Lowering priority per https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: b13534de022972131b46f93f5ada90af155eec9e
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-02-19_00:21:37
Locale: fi_FI
Comment 2 Severo Raz 2015-04-17 19:16:51 UTC
I disagree with this. If you are using your decimal separator key you really want to insert a decimal separator. This character happens to depend on your locale. I want commas as my decimal separators, as much as the bug reporter wants periods instead. I therefore recommend the bug reporter to change to a locale that uses periods as decimal separators.
Comment 3 Cor Nouws 2015-04-28 09:00:49 UTC
-1
Comment 4 Cor Nouws 2015-04-28 09:02:27 UTC
(coincidental I just receive a customers compliment, because the switch from OO to LibreOffice fixed this for them ;)
Comment 5 Buovjaga 2015-04-28 09:11:00 UTC
(In reply to Cor Nouws from comment #4)
> (coincidental I just receive a customers compliment, because the switch from
> OO to LibreOffice fixed this for them ;)

It seems I was not qualified to set this as NEW. I'll set to WONTFIX.