Bug Hunting Session
Bug 89525 - Impress does not export slides bullets to PPTX correctly
Summary: Impress does not export slides bullets to PPTX correctly
Status: RESOLVED DUPLICATE of bug 77881
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.3 target:4.4.7
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-21 09:40 UTC by Ljiljan
Modified: 2016-10-25 19:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparision between LO slide bullets and Power Point bullets (19.06 KB, image/jpeg)
2015-02-21 09:40 UTC, Ljiljan
Details
Simple Test Case does not export to PPTX (11.01 KB, application/vnd.oasis.opendocument.presentation)
2015-04-18 08:52 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2015-02-21 09:40:26 UTC
Created attachment 113573 [details]
Comparision between LO slide bullets and Power Point bullets

LibreOffice Impress export slides' bullets correctly in PPTX format (PPT is just fine). 

Bullets are always displayed in different way, using "non-bullet" symbols. Text spacing is not adequate either. 

Illustration of this problem is attached.
Comment 1 Ljiljan 2015-02-21 09:41:43 UTC
I wanted to say "...does not export correctly" :)
Comment 2 A (Andy) 2015-02-22 13:23:55 UTC
Reproducible with LO 4.4.0.3, Win 8.1

This does not happen to the same extent if you save it as ppt.  After saving as ppt the bullets are still there and to a certain extent comparable to the ones in LO, but nevertheless there some discrepancies, e.g. change of size, thickness, height.
Comment 3 Luke 2015-04-18 08:52:09 UTC
Created attachment 114875 [details]
Simple Test Case does not export to PPTX
Comment 4 Luke 2015-05-12 03:04:51 UTC
Adding priyanka who's working on exporting bullets in PPTX.
Comment 5 Matthew Francis 2015-08-13 07:58:15 UTC
Not clear why this was linked to the earlier report rather than just marked as a duplicate. If there's a reason please comment - thanks

*** This bug has been marked as a duplicate of bug 77881 ***
Comment 6 Commit Notification 2015-08-25 12:01:10 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=65a66d41fd0e13d0aad9df935091b731b4af650a

Fix tdf#77881,tdf#80520,tdf#89525 bulllets lost issue.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-09-04 01:35:27 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=382bdb8ea1a1aca10752e9124f4fb6bef9e755c8&h=libreoffice-5-0

Fix tdf#77881,tdf#80520,tdf#89525 bulllets lost issue.

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-11-24 12:03:07 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84892a9dc80917c1ca45c6eed356bfb38e8b81fb&h=libreoffice-4-4

Fix tdf#77881,tdf#80520,tdf#89525 bulllets lost issue.

It will be available in 4.4.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-11-24 17:23:58 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-4-4-7":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c54c54d9b95e15dc7179eb0399c242295b1dbf26&h=libreoffice-4-4-7

Fix tdf#77881,tdf#80520,tdf#89525 bulllets lost issue.

It will be available in 4.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.