Download it now!
Bug 89594 - EDITING PASTE CRASH
Summary: EDITING PASTE CRASH
Status: RESOLVED DUPLICATE of bug 60021
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-23 17:54 UTC by Enio
Modified: 2015-05-12 11:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Clipboard rtf contents (3.01 KB, application/rtf)
2015-04-01 15:49 UTC, Buovjaga
Details
Clipboard xml contents (800 bytes, text/xml)
2015-04-01 15:50 UTC, Buovjaga
Details
Calc spreadsheet that freezes calc (32.01 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-05-09 15:03 UTC, kie000
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Enio 2015-02-23 17:54:50 UTC
I copy and paste a sheet from Excel, which crashes calc.

It seems to happen when pasting a sheet over another, particularly when overwriting. 

I have tested and seems to happen when pasting even if in the existing sheet one cell contains a single letter.

It also crashed when pasting a column.

My steps:
CTRL + A, CTRL + C in Excel then CTRL + A, CTRL + V in Calc.
Comment 1 Buovjaga 2015-03-16 18:50:42 UTC
(In reply to sfm.neo from comment #0)
> My steps:
> CTRL + A, CTRL + C in Excel then CTRL + A, CTRL + V in Calc.

Reproduced.

Win 8 32-bit
MSO 2013
LibreOffice Version: 4.5.0.0.alpha0+
Build ID: 460b17d2712a80331a83329d2951f3e0303835cd
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-14_23:10:42
Locale: fi_FI
Comment 2 Buovjaga 2015-04-01 15:49:50 UTC
Created attachment 114529 [details]
Clipboard rtf contents

RTF data from a ctrl-a, ctrl-c from Excel 2013. Captured using http://www.nirsoft.net/utils/inside_clipboard.html
Comment 3 Buovjaga 2015-04-01 15:50:29 UTC
Created attachment 114530 [details]
Clipboard xml contents

XML data from a ctrl-a, ctrl-c from Excel 2013.
Comment 4 kie000 2015-05-09 14:42:26 UTC
Pasting from the following web page crashes calc:

http://en.wikipedia.org/wiki/List_of_countries_by_electricity_production_from_renewable_sources

2nd Table entitle 'All Countries'


even just copying the titles + 13 rows crashes calc when that is pasted into a new spreadsheet, calc freezes for a while first.

Error thrown:
osl::Thread::create failed
Comment 5 kie000 2015-05-09 15:03:29 UTC
Created attachment 115474 [details]
Calc spreadsheet that freezes calc

Data copied in to spread sheet from 2nd table here (all countries)
http://en.wikipedia.org/wiki/List_of_countries_by_electricity_production_from_renewable_sources

This spreadsheet is 100% made in Calc, LibreOffice 4.4.1.2

Calc freezes, not much CPU usage - a lot less than 1% of 1 core.

After a few minutes calc crashes with:

osl::Thread::create failed
Comment 6 kie000 2015-05-09 15:05:07 UTC
Contents of the spreadsheet I uploaded are lost after libreoffice recovery.
Comment 7 kie000 2015-05-09 15:11:31 UTC
It opened this time, how can an application behave differently from one occasion to the next!!!!!!!!!!!!!!
Comment 8 Timur 2015-05-11 18:26:16 UTC
Is the original report a duplicate of Bug 60021?
The second report seems different and new to LO 4.4, please search for similar reports and if not found open a new bug.
Comment 9 Timur 2015-05-12 11:21:37 UTC
OK, I'll close this one as a duplicate of Bug 60021. 
It's not relevant that data is from Excel, but Ctrl+A before paste.
Feel free to reopen if tests show otherwise.

I filed the second report as Bug 91237.

*** This bug has been marked as a duplicate of bug 60021 ***