Bug Hunting Session
Bug 89617 - Sifr icon style "Print document directly" icon same as "Print"
Summary: Sifr icon style "Print document directly" icon same as "Print"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Papamatti
URL:
Whiteboard: target:5.0.0 target:4.4.3
Keywords:
Depends on:
Blocks: Print-Directly Icon-Theme-Sifr-old
  Show dependency treegraph
 
Reported: 2015-02-24 14:53 UTC by S.
Modified: 2017-09-24 09:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Tango style differentiates "Print" and "Print directly" (9.78 KB, image/png)
2015-02-24 14:54 UTC, S.
Details
Sifr style "Print" and "Print directly" are indentical (6.94 KB, image/png)
2015-02-24 14:54 UTC, S.
Details
really bad mockup (313 bytes, image/png)
2015-04-11 13:04 UTC, S.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. 2015-02-24 14:53:27 UTC
Hello,

When using the Sifr icon style, the "Print document directly" icon (prints directly to the default printer with no option dialog) is exactly the same as the regular "Print" icon (brings up the print options dialog first). They should be differentiated visually, as is done in the old Tango style. 

I am attaching two screenshots for reference.

Thanks for fixing this!
Comment 1 S. 2015-02-24 14:54:03 UTC
Created attachment 113637 [details]
Tango style differentiates "Print" and "Print directly"
Comment 2 S. 2015-02-24 14:54:36 UTC
Created attachment 113638 [details]
Sifr style "Print" and "Print directly" are indentical
Comment 3 A (Andy) 2015-02-24 21:17:25 UTC
Reproducible with LO 4.4.0.3, Win 8.1
Comment 4 Papamatti 2015-04-11 12:27:50 UTC
Any suggestions? :-)

We have only 16x16 pixel and 24x24 pixel size.

Perhaps you could upload a mockup above or you create an icon as proposal by yourself and I could upload it for you.

(And of course we need always help to create more icons for sifr. https://github.com/libodesign/icons)
Comment 5 S. 2015-04-11 13:04:43 UTC
Created attachment 114738 [details]
really bad mockup

I'm definitely the world's worst artist, but I was thinking it could be the printer with a lightning bolt on the page coming out, to denote that it's a fast/direct print button.
Comment 6 Yousuf Philips (jay) (retired) 2015-04-11 18:35:37 UTC
I'm assuming that using tango as the source of the metaphor, as what is done normally, is the simplest way to fix the issue. So we take the standard print icon and add a lighting bolt through it. The lighting bolt is also used oxygen.
Comment 7 Papamatti 2015-04-11 20:23:18 UTC
Hey your icon looks like a mix of breeze and sifr style. :-)

I did a version with a flash inside like in tango/oxygen which Jay suggested.
Perhaps Jay could cherrypick the icons for 4.4?
Comment 8 S. 2015-04-11 20:35:55 UTC
Thanks a lot guys for getting this little papercut fixed!
Comment 9 Commit Notification 2015-04-11 20:53:21 UTC
Matthias Freund committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b9b6957ff3fcd2d5828bc2e23e6781fb5292cd63

tdf#89617 Sifr icon style "Print document directly" icon same as "Print"

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 S. 2015-04-11 21:18:39 UTC
(In reply to Commit Notification from comment #9)
> Matthias Freund committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=b9b6957ff3fcd2d5828bc2e23e6781fb5292cd63
> 
> tdf#89617 Sifr icon style "Print document directly" icon same as "Print"
> 
> It will be available in 5.0.0.

Nice! Is there any way this fix could be included in the next 4.4.x release?
Comment 11 Yousuf Philips (jay) (retired) 2015-04-11 21:37:40 UTC
(In reply to S. from comment #10)
> Nice! Is there any way this fix could be included in the next 4.4.x release?

Yes i've cherry picked it for 4.4, so it will be in the 4.4.3 release.
Comment 12 S. 2015-04-11 21:46:56 UTC
Sweet, thanks Jay!
Comment 13 Commit Notification 2015-04-11 22:33:07 UTC
Matthias Freund committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aac6629179d8fd0ace27f42203b6fa54b40c34f2&h=libreoffice-4-4

tdf#89617 Sifr icon style "Print document directly" icon same as "Print"

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.