Bug 89688 - VIEWING Read-only infobar steals keyboard focus on opening a document
Summary: VIEWING Read-only infobar steals keyboard focus on opening a document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
: 93690 95636 96362 101290 104455 104515 105632 (view as bug list)
Depends on:
Blocks: Infobar-UX
  Show dependency treegraph
 
Reported: 2015-02-26 15:45 UTC by Bernard Moreton
Modified: 2017-05-12 10:25 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
example to illustrate the issue (1.17 KB, application/rtf)
2015-02-27 17:00 UTC, Bernard Moreton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Moreton 2015-02-26 15:45:55 UTC
I use read-only mode a lot, and the infobar(This document is open in read-only mode) prevents any navigation on the document until either the X  or the edit-now button is clicked.  The latter stops the whole point of opening in read-only mode, and the  infobar introduces an unwanted extra step in the workflow.  Is there any way (prefably in the command-line options) to switch this infobar off?
Comment 1 Adolfo Jayme 2015-02-27 04:53:11 UTC
Do you mean the keyboard focus is not in the document when the infobar is open? Because I can’t reproduce that issue.
Comment 2 Joel Madero 2015-02-27 04:59:09 UTC
@Bernard -

I am marking this as NEEDINFO. Please provide very clear reproducible steps (assume you are explaining it to someone who never uses read-only mode) on what you are seeing as well as your operating system. Once you do this, set the bug to UNCONFIRMED. Thanks
Comment 3 Bernard Moreton 2015-02-27 17:00:47 UTC
Created attachment 113759 [details]
example to illustrate the issue
Comment 4 Bernard Moreton 2015-02-27 17:06:51 UTC
On Ubuntu 12.04 LTS, calling
soffice --view demo.rtf
opens the (2-page) document in read-only mode.

PageDown and down arrow are not effective until EITHER the infobar is closed OR the cursor is clicked on the document to get focus.

The primary invitation on the infobar to "Edit document" subverts the security of opening in read-only mode; and the information on the infobar duplicates what is already shown in the LibreOffice window header.
Comment 5 Buovjaga 2015-03-04 14:28:06 UTC
(In reply to Bernard Moreton from comment #4)
> On Ubuntu 12.04 LTS, calling
> soffice --view demo.rtf
> opens the (2-page) document in read-only mode.
> 
> PageDown and down arrow are not effective until EITHER the infobar is closed
> OR the cursor is clicked on the document to get focus.

Confirmed.

Lowered importance & severity per https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Ubuntu 14.10 64-bit 
Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US
Comment 6 Buovjaga 2015-09-12 14:56:00 UTC
*** Bug 93690 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2015-12-14 10:19:19 UTC
*** Bug 95636 has been marked as a duplicate of this bug. ***
Comment 8 Buovjaga 2015-12-14 10:19:46 UTC
*** Bug 96362 has been marked as a duplicate of this bug. ***
Comment 9 Buovjaga 2015-12-14 10:20:58 UTC
Rethinking prioritization due to accessibility concerns.
Comment 10 Buovjaga 2016-08-07 15:38:30 UTC
*** Bug 101290 has been marked as a duplicate of this bug. ***
Comment 11 Buovjaga 2016-12-09 20:35:05 UTC
*** Bug 104455 has been marked as a duplicate of this bug. ***
Comment 12 Buovjaga 2016-12-09 20:53:38 UTC
*** Bug 104515 has been marked as a duplicate of this bug. ***
Comment 13 Buovjaga 2017-02-03 18:24:24 UTC
*** Bug 105632 has been marked as a duplicate of this bug. ***
Comment 14 Bernard Moreton 2017-02-17 09:37:46 UTC
The problem no longer appears in 5.3.0.3, so is probably fixed?  Thank you all!
Comment 15 Buovjaga 2017-02-17 11:14:30 UTC
By the gods, you are right!

Closing as WFM.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 4cdd4b47ba62a75aadfd5cab166acfdbc31b9b71
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 17th 2016