Bug 89694 - Password dialog will display percent-encoded file path when opening OOXML (named with multibyte characters).
Summary: Password dialog will display percent-encoded file path when opening OOXML (na...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.1.1 rc
Hardware: Other All
: low minor
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0
Keywords:
Depends on:
Blocks: Password-Protected
  Show dependency treegraph
 
Reported: 2015-02-26 20:48 UTC by jun meguro
Modified: 2018-11-06 03:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample document. (8.00 KB, application/x-ole-storage)
2015-02-26 20:48 UTC, jun meguro
Details
screen shot (205.72 KB, image/png)
2015-02-26 20:50 UTC, jun meguro
Details
A half-coocked patch (966 bytes, patch)
2015-02-28 05:05 UTC, Tomofumi Yagi
Details
Modified patch is here. (1.24 KB, patch)
2015-03-08 05:39 UTC, Tomofumi Yagi
Details
Screen shot(decodec with rtl_UriDecodeWithCharset parameter). (5.49 KB, image/png)
2015-03-08 05:43 UTC, Tomofumi Yagi
Details
Screen shot(decodec with rtl_UriDecodeToIuri parameter). (5.67 KB, image/png)
2015-03-08 05:44 UTC, Tomofumi Yagi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jun meguro 2015-02-26 20:48:40 UTC
Created attachment 113718 [details]
sample document.

1,Open attached OOXML Document "無題1.xlsx".
2,Passwod diarog will open.
3,File path contains garbled texts.
Comment 1 jun meguro 2015-02-26 20:50:30 UTC
Created attachment 113719 [details]
screen shot
Comment 2 Adolfo Jayme 2015-02-27 03:15:37 UTC
Thanks for your bug report.
Comment 3 Tomofumi Yagi 2015-02-28 05:05:11 UTC
Created attachment 113772 [details]
A half-coocked patch

Blind fix is here.
Comment 4 Tomofumi Yagi 2015-03-08 05:39:18 UTC
Created attachment 113965 [details]
Modified patch is here.
Comment 5 Tomofumi Yagi 2015-03-08 05:43:00 UTC
Created attachment 113966 [details]
Screen shot(decodec with rtl_UriDecodeWithCharset parameter).
Comment 6 Tomofumi Yagi 2015-03-08 05:44:49 UTC
Created attachment 113967 [details]
Screen shot(decodec with rtl_UriDecodeToIuri parameter).
Comment 7 Commit Notification 2015-10-20 09:42:58 UTC
Tomofumi Yagi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7660e4dcecfb19ad8e9e21e5fe53637bd1b9dc6c

tdf#89694 Password dialog for opening OOXML shows url-encoded path

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2016-09-15 22:20:22 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2017-11-05 22:02:14 UTC
A polite ping to Tomofumi Yagi: is this bug fixed? if so, could you please
close it as RESOLVED FIXED ? Thanks
Comment 10 QA Administrators 2018-11-06 03:55:45 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug