Bug Hunting Session
Bug 89695 - DICTIONARIES: Updating the english dictionaries
Summary: DICTIONARIES: Updating the english dictionaries
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Marco A.G.Pinto
URL:
Whiteboard:
Keywords:
: 105058 (view as bug list)
Depends on:
Blocks: Dictionaries
  Show dependency treegraph
 
Reported: 2015-02-26 22:07 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-06-24 11:44 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-02-26 22:07:23 UTC
Kevin Atkinson has created an updated english hunspell dictionaries ( http://wordlist.aspell.net/dicts/ ) and it would be useful to integrate it within LibreOffice as it is currently being integrated into Mozilla ( https://bugzilla.mozilla.org/show_bug.cgi?id=1133363 ).

It would be good to try and push the changes in LibreOffice's dictionaries upstream to Kevin or alternatively push it into Mozilla and then LibreOffice to use one of the two as its upstream.

https://hg.mozilla.org/mozilla-central/file/tip/extensions/spellcheck/locales/en-US/hunspell
Comment 1 Robinson Tryon (qubit) 2015-02-26 23:00:34 UTC
(In reply to Jay Philips from comment #0)
> Kevin Atkinson has created an updated english hunspell dictionaries (
> http://wordlist.aspell.net/dicts/ ) and it would be useful to integrate it
> within LibreOffice

If it's a better dictionary, easy to integrate, and license-compatible, then that sounds good to me.

Status -> NEW
Comment 2 Yousuf Philips (jay) (retired) 2015-03-03 05:03:11 UTC
When I asked Nemeth by email about pushing LibreOffice's changes upstream into Kevin's or Mozilla's work, he stated:

--------------------------

It would be better the upstream support, or a more simple patching process (the original part-of-speech/morphological data extender scripts are attached to an old OpenOffice.org issue), but Firefox hasn't used thesauri, yet (Safari does it).

--------------------------

So what i get from this is that the our en-US.aff cant be upstreamed, but can en-US.dic?

Was searching through the OOo bugzilla and found the bug where i believe the dictionary files were last updated from - https://bz.apache.org/ooo/show_bug.cgi?id=92383
Comment 3 Yousuf Philips (jay) (retired) 2015-05-07 21:07:53 UTC
I had opened a github issue at Kevin's repo where i filed the same issue - https://github.com/kevina/wordlist/issues/104
Comment 4 Kevin Atkinson 2015-05-10 18:38:41 UTC
> Was searching through the OOo bugzilla and found the bug where i believe the
> dictionary files were last updated from -
> https://bz.apache.org/ooo/show_bug.cgi?id=92383

I don't believe the dictionary refereed to in that bug report was ever used.  For one thing he only released it under the GPLv3.

Per an agreement with Nemeth several years ago, I am the official maintainer of the American Hunspell dictionary, at least for the contents of the dictionary.  I do not believe the American dictionary from Nemeth has been updated in a long time.

I wrote some scripts to help Mozilla upgrade to the latest upstream version, see https://bugzilla.mozilla.org/show_bug.cgi?id=1137544.  I am not sure I have the time to do the same for LibreOffice, but perhaps someone can use those scripts as a starting point.
Comment 5 Yousuf Philips (jay) (retired) 2015-05-15 22:32:40 UTC
AOO seems to be regularly updating their english dictionaries.

http://extensions.openoffice.org/en/project/english-dictionaries-apache-openoffice
Comment 6 Marco A.G.Pinto 2016-02-09 10:41:05 UTC
Yes, it is me who is updating AOO English Dictionaries monthly.

For a few months that I have also placed the OXT at LO's Extensions page:
http://extensions.libreoffice.org/extension-center/english-dictionaries

It would be great if it could be integrated into LO.

Also, take a look at the project page:
http://marcoagpinto.cidadevirtual.pt/proofingtoolgui.html

And my GitHub from where you can download individual files:
https://github.com/marcoagpinto/aoo-mozilla-en-dict

At least you could integrate the British speller since I added 18'000+ new words since I embraced the task around 2-3 years ago.
Comment 7 V Stuart Foote 2017-01-03 14:45:13 UTC
*** Bug 105058 has been marked as a duplicate of this bug. ***
Comment 8 Yousuf Philips (jay) (retired) 2017-06-24 11:21:59 UTC
So Marco pushed Kevin's dictionaries and his en_GB dictionary into master.

https://gerrit.libreoffice.org/#/c/34751/

He's also trying to get more works into the en_US dictionary in this github issue.

https://github.com/en-wl/wordlist/issues/181