Download it now!
Bug 89791 - DOCX: dont save custom.xml if its empty
Summary: DOCX: dont save custom.xml if its empty
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:4.5.0 target:4.4.2
Keywords: filter:docx
Depends on:
Blocks:
 
Reported: 2015-03-03 02:52 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-17 04:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-03-03 02:52:36 UTC
When saving to docx, LibreOffice will have the /docProps/custom.xml file even when it doesnt contain any data.

Version: 4.5.0.0.alpha0+
Build ID: 4cf69df2f543b023f4ec3d4279c5ac11a2a819d9
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-02-21_03:46:34
Comment 1 Julien Nabet 2015-03-03 22:47:59 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 2 Julien Nabet 2015-03-03 22:48:16 UTC
https://gerrit.libreoffice.org/#/c/14735/
Comment 3 Commit Notification 2015-03-09 21:04:44 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97c9bc9fada9cdfff956101a4a5e264b4dba58be

tdf#89791: DOCX: don't save custom.xml if it's empty

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Julien Nabet 2015-03-09 21:12:27 UTC
For 4.4 branch: https://gerrit.libreoffice.org/#/c/14815/
(I don't think it worth it to cherry-pick the patch for 4.3 since it's not a crash or something annoying)
Comment 5 Commit Notification 2015-03-10 15:04:36 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ddb0bdef30dfb609378b73eb1a429943078bd611&h=libreoffice-4-4

tdf#89791: DOCX: don't save custom.xml if it's empty

It will be available in 4.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Yousuf Philips (jay) (retired) 2015-03-11 09:05:56 UTC
Thanks for fixing this Julien.

(In reply to Julien Nabet from comment #4)
> (I don't think it worth it to cherry-pick the patch for 4.3 since it's not a
> crash or something annoying)

Totally agree. :D
Comment 7 Commit Notification 2015-03-22 18:37:20 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=009762b05131760144dbd2af8900ee2b84077564

Related tdf#89791: Add unit test

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Robinson Tryon (qubit) 2015-12-17 04:37:59 UTC
Migrating Whiteboard tags to Keywords: (filter:docx)
[NinjaEdit]