Download it now!
Bug 89832 - Titlebar displays the wrong language in Base when certain language sets are installed
Summary: Titlebar displays the wrong language in Base when certain language sets are i...
Status: RESOLVED DUPLICATE of bug 83535
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-04 23:06 UTC by John T. Haller
Modified: 2015-03-05 16:58 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Table Design shown in Chinese Traditional (1.41 KB, image/png)
2015-03-04 23:06 UTC, John T. Haller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John T. Haller 2015-03-04 23:06:58 UTC
Created attachment 113897 [details]
Table Design shown in Chinese Traditional

When in Base with LibreOffice UI set to English, selecting "Create a Table in Design View" results in a window with a titlebar with non-English characters (see attached).  The text should read "LibreOffice Base: Table Design". Instead, the word Table Design is shown in Chinese Traditional.

This appears to only occur with specific sets of languages installed.  Installing only English or installing all languages will not trigger the bug.  Installing a specific set of languages will cause it to occur.  In my case, the set was Arabic, Chinese, English, French, German, Italian, Japanese, Korean, Portuguese, Russian, and Spanish.

Oddly, copying registry_zu.xcd for Zulu from a full install within the LibreOffice 4\share\registry\res directory to the broken install fixes the problem.

I noticed this bug introduced in LibreOffice 4.4.0 when packaging the portable version's popular language set for PortableApps.com.  I worked around the the issue in LibreOffice Portable 4.4.1 by including the above-mentioned Zulu file.
Comment 1 Adolfo Jayme 2015-03-05 16:58:47 UTC
Thank you for submitting for your bug report. This specific one is a duplicate of an earlier one regarding the same issue, so I’ll mark it as such. You’ll be automatically subscribed to the other one. Please feel free to add any details you may think are missing in the other report.

*** This bug has been marked as a duplicate of bug 83535 ***