Bug 89841 - [Calc] Autofilter - weak indication that autofilter was set
Summary: [Calc] Autofilter - weak indication that autofilter was set
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Tünde Tóth
URL:
Whiteboard: target:7.2.0
Keywords: needsUXEval
: 122349 138929 (view as bug list)
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2015-03-05 11:38 UTC by wabik
Modified: 2021-03-16 09:32 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Shadow around filtered cells (3.29 KB, image/png)
2019-07-13 07:44 UTC, Heiko Tietze
Details
Blue row numbers (24.28 KB, image/png)
2021-02-01 14:38 UTC, Tünde Tóth
Details
Mockup of whole autofilter being blue (1.42 KB, image/png)
2021-02-01 18:26 UTC, Toby
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wabik 2015-03-05 11:38:24 UTC
There is almost no indication that Autofilter was applied ...

Only one blue triangle on top ... But it should be at least like in Excel:

Blue triangle and blue row numbers when Autofilter selected!

Thank you in advance!

WHY:
Because when you are searching for some values and autofilter is applied and the value is in others cells (then these applied) you do not get any results like your value do not exist!!! 
And you can draw really bad conclusions; Like I did :(((

Thank you in advance!
Comment 1 raal 2015-03-05 13:49:39 UTC
valid enhancement, setting to new.
Comment 2 Aron Budea 2019-07-12 00:35:23 UTC
*** Bug 122349 has been marked as a duplicate of this bug. ***
Comment 3 Aron Budea 2019-07-12 00:38:34 UTC
This is what it looks like in Excel, see section "How to apply filter in Excel":
https://www.ablebits.com/office-addins-blog/2016/08/31/excel-filter-add-use-remove/

Let's add the UX team for guidance.
Comment 4 Heiko Tietze 2019-07-13 07:44:06 UTC
Created attachment 152751 [details]
Shadow around filtered cells

The border might be used (and we shouldn't just copy) so how about a shadow? By doing this we could also get rid of the triangle in fully saturated blue and use some default color.

bug 76389 might be solved when this is being touched.
Comment 5 Tünde Tóth 2021-02-01 14:38:09 UTC
Created attachment 169350 [details]
Blue row numbers

Screenshot about the result of this commit: https://gerrit.libreoffice.org/c/core/+/110130
Comment 6 kabilo 2021-02-01 15:14:37 UTC
*** Bug 138929 has been marked as a duplicate of this bug. ***
Comment 7 kabilo 2021-02-01 15:35:10 UTC
Hi,
great job, finally it will not be necessary to check all columns if the autofilter is off.
Will the blue tint also work for a standard filter?
Thanks
Comment 8 Toby 2021-02-01 18:23:48 UTC
I am 51 and my eyesight is not so good as it was.

On the autofilter I find it very difficult to see the difference between the black arrow and the blue one. The dot is also very small.

Would you consider colouring the whole square icon blue, to make it easy to see which columns are filtered please?

I'll add an example as a attachment
Comment 9 Toby 2021-02-01 18:26:03 UTC
Created attachment 169363 [details]
Mockup of whole autofilter being blue

I find it very difficult to see the difference between the blue and black arrows on the autofilter. I also find the small dot difficult to see.

Would you consider making the whole box blue (perhaps with a white arrow) to make the filter much more obvious?

Thanks
Comment 10 Gabor Kelemen 2021-02-02 07:31:11 UTC
(In reply to kabilo from comment #7)
> Will the blue tint also work for a standard filter?

Hi

I compiled the patch and unfortunately it does not. I'll file a new bug about that - and also about the fact that an applied standard filter is currently not visible at all.
Comment 11 Commit Notification 2021-03-11 11:15:07 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9bba5f418d4900ba20503dd1d310b3ff68bb14df

tdf#89841 sc UI: show blue row numbers for filtered rows

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Roman Kuznetsov 2021-03-16 09:32:28 UTC
Verified in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d97528da0c70c43fccd3239cbe8e064c3480bba8
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: CL

Thanks for implementig it, Tünde Tóth