Bug Hunting Session
Bug 89866 - The images in the controls picto do not print
Summary: The images in the controls picto do not print
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:5.2.0 target:5.1.4
Keywords: regression
: 96504 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-06 21:08 UTC by Thehache
Modified: 2016-10-25 19:03 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
File .ods with control picto with picture (28.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-03-07 08:20 UTC, Thehache
Details
file .odt with control picto with picture (26.50 KB, application/vnd.oasis.opendocument.text)
2015-03-07 08:21 UTC, Thehache
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thehache 2015-03-06 21:08:34 UTC
Hello,

The images in the controls picto do not print and print to a .pdf file does not work either. The print preview in turn displays the image. Problems encountered on LibO V4.3.4.1 with Win7 Ent., LibO 4.4.0.3 with Win 7 Fam., 4.4.1 Mac OSX LibO 10.10.2.
No problem on previous versions. No problem on Ubuntu 14.04 LTS with V4.2.7.2.
Comment 1 Jean-Baptiste Faure 2015-03-07 07:14:29 UTC
Please, attach your test file to this bug report.

Setting status to NEEDINFO, set it back to UNCONFIRMED once you have provided requested informations.

Best regards. JBF
Comment 2 Thehache 2015-03-07 08:20:43 UTC
Created attachment 113942 [details]
File .ods with control picto with picture
Comment 3 Thehache 2015-03-07 08:21:18 UTC
Created attachment 113943 [details]
file .odt with control picto with picture
Comment 4 Jean-Baptiste Faure 2015-03-07 08:39:31 UTC
(In reply to Thehache from comment #2)
> Created attachment 113942 [details]
> File .ods with control picto with picture

Thank you. Set status back to unconfirmed.

Best regards. JBF
Comment 5 raal 2015-03-13 10:09:25 UTC
I can confirm with  4.4.1.2
ID build: 45e2de17089c24a1fa810c8f975a7171ba4cd432, win7
Tested export to PDF, preview correct, export without picture.
Comment 6 Matthew Francis 2015-03-18 03:20:55 UTC
The only version I can get to export attachment 113943 [details] properly as a PDF is 3.3.0.4 on OSX. 3.4.6.2 onwards on OSX, and the 43all bibisect tree from the start on Linux (i.e. ~3.5 onwards) all fail to export the image.

This result is confusing in light of comment 0. I specifically can't find any version that works in the region of 4.2.

@Thehache: Can you confirm that you can export this specific file to PDF from 4.2.7.2, with the image? If so, are you using the official Document Foundation packages, or from another source? And, are you using a 32bit or 64bit system?


Setting status to NEEDINFO. Please set back to NEW when the requested information has been provided
Comment 7 Thehache 2015-03-23 09:20:29 UTC
Hello,

I confirm that with the 4.2.7.2 version of PDF export file works, the printing paper also works.
Use of official UBUNTU 14.04 LTS packages under 64bit.

Best Regards
Comment 8 QA Administrators 2015-10-14 19:50:57 UTC Comment hidden (obsolete)
Comment 9 Jean-Baptiste Faure 2015-10-17 20:52:45 UTC
Question in comment #6 has been provided in comment #7. Set status back to NEW.

Best regards. JBF
Comment 10 raal 2015-12-20 14:00:26 UTC
linux /bibisect-43all$ git checkout oldest - contains bug too
Comment 11 Michael Stahl (CIB) 2016-04-27 16:49:28 UTC
on Linux, regression from commit f749ffbdf4c007f1a42bcafc9c2723c47bac22d1
which was misled by a DBG_ASSERT in the code that was actually wrong

however for me LO 4.2.8 does not actually print the image successfully;
it's not obvious how this would have worked before.

... for me OOo 3.3 could print and PDF-export the image
and OOo 3.4 beta and everything newer not.

fixed on master
Comment 12 Commit Notification 2016-04-27 16:51:27 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ef52ce82bf55b37279e344ea5fef67b4277fb009

tdf#89866 tdf#96504 vcl: fix printing of form controls with images

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Michael Stahl (CIB) 2016-04-27 16:51:57 UTC
*** Bug 96504 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2016-04-28 06:50:20 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b63c3d9bd9e616a7d38df6f12226cc3b5fd65c2d&h=libreoffice-5-1

tdf#89866 tdf#96504 vcl: fix printing of form controls with images

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.