Download it now!
Bug 89893 - When a document is in read-only mode, Edit->Track Changes->{Next, Previous} Change are greyed out
Summary: When a document is in read-only mode, Edit->Track Changes->{Next, Previous} C...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: Other All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.2.0 target:6.1.0.2
Keywords:
Depends on:
Blocks: Track-Changes Read-Only
  Show dependency treegraph
 
Reported: 2015-03-08 19:43 UTC by Reuben Thomas
Modified: 2018-07-17 09:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reuben Thomas 2015-03-08 19:43:51 UTC
When I open a read-only document, I can see the changes (using Edit->Track Changes->Show Changes), but I can't go from one to the next using Previous/Next Change, so it's hard to be sure I've seen them all.

This may be related to #65781, although I don't see why merely looking at the changes should require the document to be editable.
Comment 1 A (Andy) 2015-03-14 10:18:37 UTC
Reproducible with LO 4.4.1.2, Win 8.1.  

Of course, you opened the document as Read-Only, but because you can also use the Show Changes function it should be possible to use the Previous and Next buttons too, but of course without any Accept or Reject possibility as long as you are in the Read-Only mode.
Comment 2 tommy27 2016-04-16 07:24:13 UTC Comment hidden (obsolete)
Comment 3 Reuben Thomas 2016-04-16 11:20:43 UTC
The bug still occurs in exactly the same form in LO 5.1.2.2 (GNU/Linux).
Comment 4 QA Administrators 2017-05-22 13:24:54 UTC Comment hidden (obsolete)
Comment 5 Reuben Thomas 2017-05-22 13:39:49 UTC
Bug still present exactly as reported in 5.3.3.
Comment 6 QA Administrators 2018-07-02 02:34:45 UTC Comment hidden (obsolete)
Comment 7 Reuben Thomas 2018-07-02 15:47:37 UTC
Bug still present as described in 6.0.5.
Comment 8 Xisco Faulí 2018-07-06 22:43:46 UTC
Submitted a path to gerrit: https://gerrit.libreoffice.org/#/c/57100/
Comment 9 Commit Notification 2018-07-08 11:50:25 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eedeeb63d1287ed0416e1fe3d2f7ba37632626d0

tdf#89893: Enable previous/next track changes in read-only mode

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-07-17 09:07:08 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db843c97279924fd36f31c8f22269f804f5add07&h=libreoffice-6-1

tdf#89893: Enable previous/next track changes in read-only mode

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Reuben Thomas 2018-07-17 09:24:50 UTC
This is brilliant, thanks so much for the fix!