Bug Hunting Session
Bug 89929 - FILEOPEN: Image is flipped horizontally in PPTX
Summary: FILEOPEN: Image is flipped horizontally in PPTX
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 90537 (view as bug list)
Depends on:
Blocks: Impress-Images
  Show dependency treegraph
 
Reported: 2015-03-10 11:41 UTC by Andrei Cristian Petcu
Modified: 2016-11-28 20:29 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
File content image having horizontal flips (254.92 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-04-16 09:29 UTC, Yogesh Bharate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Cristian Petcu 2015-03-10 11:41:05 UTC
Hello, 

The image that looks like some radio/wifi waves is flipped in one direction in Impress and in another direction in PowerPoint. Please check out the attached files in bug #89928 .

I don't want to upload them twice and waste space. I reported 2 different bugs on the same file. If you wish I can re-upload the files here also.
Comment 1 A (Andy) 2015-03-11 21:54:37 UTC
Reproducible with LO 4.4.1.2, Win 8.1

The right image (part) is mirrored when comparing it with IMPRESS and PowerPoint.
Comment 2 Matthew Francis 2015-03-20 08:01:41 UTC
Reproduced in LibreOffice 3.3.0.4/OSX.
OOo 3.3.0 also shows it the same way, so
-> Inherited from OOo
Comment 3 Yogesh Bharate 2015-04-16 09:29:41 UTC
Created attachment 114820 [details]
File content image having horizontal flips
Comment 4 Xisco Faulí 2015-09-04 11:41:29 UTC
*** Bug 90537 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2015-09-04 11:42:36 UTC
This issue is still present in

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 6 Juergen Weismueller 2016-02-03 13:16:50 UTC
Hallo LibreOffice Team, 
is there any chance that we could expect this issue to be resolved within the next LibreOffice release? Thank you very much for feedback!
Comment 7 Xisco Faulí 2016-02-03 13:33:40 UTC
It looks like flip problem is no longer reproducible in

Version: 5.2.0.0.alpha0+
Build ID: 91c072b473beadda01a38dbc26086207c7b4d145
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-02_06:12:40
Locale: es-ES (es_ES)

However, the image's position isn't correct in this version
Comment 8 Timur 2016-02-03 18:57:36 UTC
(In reply to Xisco Faulí from comment #7)
> It looks like flip problem is no longer reproducible in 5.2.0.0.alpha0+
Seems so. But looks to me like a dupe of Bug 35913.

> However, the image's position isn't correct in this version
Actually, it's fileopen problem from 5.1.
Comment 9 Xisco Faulí 2016-11-28 16:11:35 UTC
it looks this issue is no longer reproducible in

Version: 5.4.0.0.alpha0+
Build ID: 7c5aaa254f444d54b9ebf6574f0ccd37af548ee5
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

However, if we save the document into a new .PPTX and open it again, the image is still flipped. Reported in bug 104209

Closing this as RESOLVED WORKSFORME