Bug Hunting Session
Bug 89982 - FILEOPEN Can't open particular base form (SfxBaseModel::loadFromStorage:0xf26)
Summary: FILEOPEN Can't open particular base form (SfxBaseModel::loadFromStorage:0xf26)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-13 06:50 UTC by ratrace
Modified: 2015-10-11 13:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
corrupt form file (409.31 KB, application/vnd.oasis.opendocument.database)
2015-03-13 06:50 UTC, ratrace
Details
hs_err_pid11898 (98.23 KB, text/x-log)
2015-03-14 18:51 UTC, ratrace
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ratrace 2015-03-13 06:50:43 UTC
Created attachment 114067 [details]
corrupt form file

Hello,

i'm using debian wheezy 7.8.

I can't anymore open the form "Καταχώρηση εγκύκλιος ΔΛΤ". The error message is "SfxBaseModel::loadFromStorage:0xf26".

I will create a new form to continue my work, but i'm uploading the base file in case that it is helpfull to understand why this is happening.

I had the same problem in the same or different odb files in the past.

Thanks
Comment 1 Alex Thurgood 2015-03-13 14:57:32 UTC
lldb output :

warn:legacy.osl:66590:1:sw/source/filter/xml/swxml.cxx:247: Zip exception caught while importing:
The stream seems to be broken!
warn:legacy.osl:66590:1:dbaccess/source/ui/dlg/sqlmessage.cxx:257: lcl_buildExceptionChain: useless exception: no state, no error code, no message!




Confirming on master 

Version: 4.5.0.0.alpha0+
Build ID: 34d6ec2c6e6618beacac881ec28ab527b25558d1
Locale: fr_

OSX 10.10.2
Comment 2 Alex Thurgood 2015-03-13 15:00:18 UTC
The question is : what caused the file to become like this ? Without knowing, how or why this occurred, it is going to be hard to pinpoint, but it does remind me of similar previous bug reports in which people have reported xml corruption.
Comment 3 Robert Großkopf 2015-03-13 15:38:33 UTC
I have extracted the file. The content of the form should be in forms/Obj51. Then I had a look at forms/Obj51/content.xml. This file had been extracted with 0 Byte. When opening the *.odb-file in a packing-program it is shown with 48,4 KB.
Comment 4 Julien Nabet 2015-03-14 01:24:33 UTC
After having renamed your file in zip, I confirm it's indeed corrupted:
zip -T test.zip 
  error:  invalid compressed data to inflate forms/Obj51/content.xml
  error:  invalid compressed data to inflate reports/Obj12/meta.xml
  error:  invalid compressed data to inflate reports/Obj12/ObjectReplacements/report
test of test.zip FAILED

zip error: Zip file invalid, could not spawn unzip, or wrong unzip (original files unmodified)

I tried "zip -FF", no better
(
quote from zip help page:
-F   fix zipfile (-FF try harder)
)

Was the file on local hard disk or on a share network?

Hope you had made some backup before this.
Comment 5 ratrace 2015-03-14 07:42:52 UTC
Thank you for your efforts.

The form that doesn't work was a copy of the third form, that i modified to work whith other tables. It worked for some time.

Now that doesn't work i made another copy of the initial form (third form) and modified it again.

Other than that the file works properly.

Thanks.
Comment 6 ratrace 2015-03-14 18:50:38 UTC
I found a file named "hs_err_pid11898.log" into my personal folder. I'm attaching it in case that it is helpful.
Comment 7 ratrace 2015-03-14 18:51:40 UTC
Created attachment 114093 [details]
hs_err_pid11898
Comment 8 Stephan Bergmann 2015-03-16 08:43:41 UTC
(errcode 0xf26 is ERRCODE_IO_BROKENPACKAGE, tools/errcode.hxx, matching the other comments about a broken .odb file)
Comment 9 Julien Nabet 2015-10-11 13:54:42 UTC
I don't know if if you reproduced again the behaviour but just 2 simple things to do (perhaps you already did it).
1) Upgrade to a newer LO version
2) Make a backup, rename your file in zip file and check if the zip extract is ok.

Meanwhile, let's put this one to WFM.

Don't hesitate to reopen this tracker if you find a step by step process to obtain such a corrupted file.