Bug 90069 - DOCX: Font style table inconsistencies, new cells resetting font styles
Summary: DOCX: Font style table inconsistencies, new cells resetting font styles
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:6.5.0
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2015-03-17 18:11 UTC by yndoendo
Modified: 2020-03-11 22:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yndoendo 2015-03-17 18:11:13 UTC
Creating a table and changing the font face does not propagate to child cells.  End user keeps on having to change the new cell's font face when adding on to a table.

1) Create table
2) Select cells
3) Change font face
4) Insert row
5) New cells font style does not match parent table.

All new cells created after item three use the default font face instead of the table's font face.

An end user would expect the new cell font settings to mimic the already existing adjacent cell / row.

Have not checked to see which font settings stay with in the table cell creations.  At the moment I am under the assumption that none do.
Comment 1 A (Andy) 2015-03-17 19:57:45 UTC
What do you mean with "font face"?
Comment 2 yndoendo 2015-03-17 22:56:04 UTC
Font Face; meaning all or any aspects of fonts from Family or Name, color, size, to italicized or strike through.
Comment 3 A (Andy) 2015-03-18 17:31:20 UTC
Thanks for your fast reply.

For me not reproducible with LO 4.4.1.2, Win 8.1.  Maybe a Linux only issue?
Comment 4 yndoendo 2015-03-20 01:26:34 UTC
Turns out it occurs in the Microsoft Format docx and not in the odt document format.
Comment 5 A (Andy) 2015-03-20 17:53:10 UTC
Thanks for your note.

Now it is reproducible with LO 4.4.1.2, Win 8.1

Remark to reproduce it:
Between step 3 and 4 you have to save it as a docx-file, close and reopen it.
Comment 6 tommy27 2016-04-16 07:27:31 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-05-22 13:24:29 UTC Comment hidden (obsolete)
Comment 8 Roman Kuznetsov 2019-02-01 20:27:21 UTC
still repro in

Version: 6.1.4.2
Build ID: 1:6.1.4-0ubuntu0.18.10.1
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: ru-RU (ru_RU.UTF-8); Calc: group threaded
Comment 9 Commit Notification 2020-01-09 17:00:59 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2ab481b038b62b1ff576ac4d49d03c1798cd7f84

tdf#90069 DOCX: fix character style of new table rows

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.