Bug Hunting Session
Bug 90140 - FILEOPEN: PPTX file with multiple columns has column text FORMATTING wrong
Summary: FILEOPEN: PPTX file with multiple columns has column text FORMATTING wrong
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: Matters-to-Caolan PPTX
  Show dependency treegraph
 
Reported: 2015-03-21 05:22 UTC by Luke
Modified: 2018-10-18 07:22 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of textbox with 2 columns (44.99 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-03-21 05:22 UTC, Luke
Details
Example compared MSO and 6.2 before and after fix in 120028.jpg (37.40 KB, image/jpeg)
2018-10-04 07:42 UTC, Timur
Details
Example of textbox with 3 columns PPTX (33.81 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-10-04 08:10 UTC, Timur
Details
Example compared again (111.33 KB, image/png)
2018-10-18 07:22 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-03-21 05:22:01 UTC
Created attachment 114222 [details]
Example of textbox with 2 columns

Steps to reproduce:
1. In MSO PowerPoint 2007+, select a text box.
2. Click the Home tab.
3. Go to the Paragraphs section.
4. Click the Columns button
5. Select either One, Two, Three, or More Columns. 
6. Save as PPTX
7. Open in Impress

Impress will display the text box as a single column
Comment 1 A (Andy) 2015-03-21 07:20:57 UTC
Reproducible with LO 4.4.1.2., Win 8.1
Comment 2 tommy27 2015-06-18 05:13:23 UTC
issue is still present in LibO 4.4.3.2 and recent 5.1.0.0 daily build
Comment 3 Ofir 2017-11-10 00:32:03 UTC
Reproducible with LO 6.0.0.0.alpha1 on Ubuntu 16.04.
Comment 4 Luke 2018-09-25 19:33:33 UTC
Miklos is tackling this issue over at Bug 120028. Best to track it there.

*** This bug has been marked as a duplicate of bug 120028 ***
Comment 5 Timur 2018-10-04 07:42:47 UTC
Created attachment 145365 [details]
Example compared MSO and 6.2 before and after fix in 120028.jpg

This bug started as "Add support PPTX files with multiple columns". That was done in 6.2+ as Bug 120028.
But this example attachment 114222 [details] looks different:
- bullet list is added
- center format is lost 
- font color is different.

So I'll reopen this bug. Normally we report those issues separately, but some may be fixed in other bugs, so let's keep it all here so far, at least until some change or fix is made.
Comment 6 Timur 2018-10-04 07:52:28 UTC
Comment on attachment 114222 [details]
Example of textbox with 2 columns

First example has 2 columns
Comment 7 Timur 2018-10-04 08:10:02 UTC
Created attachment 145366 [details]
Example of textbox with 3 columns PPTX

For another example with 3 columns, there's another issue of different size that results in different look.
Comment 8 Timur 2018-10-18 07:22:08 UTC
Created attachment 145798 [details]
Example compared again

As Luke noted, the look is somehow fixed now so WFM. 
What remains elsewhere is the issue with 3 columns.
Comment 9 Timur 2018-10-18 07:22:38 UTC
Tested with libo-master~2018-10-17_01.54.59_LibreOfficeDev_6.2.0.0.alpha0_Win_x86