Download it now!
Bug 90174 - FILESAVE: PPTX export color property for bullet
Summary: FILESAVE: PPTX export color property for bullet
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Priyanka Gaikwad
URL:
Whiteboard: target:4.5.0 target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-23 12:14 UTC by Priyanka Gaikwad
Modified: 2015-05-14 07:09 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
pptx with bullet color red (32.17 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-03-23 12:17 UTC, Priyanka Gaikwad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Priyanka Gaikwad 2015-03-23 12:14:42 UTC
Problem description: 
  The color of the bullet points on a presenation slide is not exported after saved as pptx in LibreOffice.

Steps to reproduce:
1. open attached pptx in Libre Office
  -> fomat looks as expected
2. save the file as pptx
3. close LibreOffice
4. Open the saved file again

Current behavior:
  After the document has been saved in LO the bullet color gets destroyed.

Expected behavior:
  The color of the bullet point should export properly.
Comment 1 Priyanka Gaikwad 2015-03-23 12:17:34 UTC
Created attachment 114272 [details]
pptx with bullet color red
Comment 2 Julien Nabet 2015-03-23 12:25:41 UTC

*** This bug has been marked as a duplicate of bug 90173 ***
Comment 3 Commit Notification 2015-03-24 15:45:43 UTC
PriyankaGaikwad committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8707670cb39f5777cd54f8b180ec342416ef259f

tdf#90174 FILESAVE: export of bullet color for pptx

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2015-03-25 10:56:48 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=46a0c8761e07226389bb2afef54817f51879e27d

Revert "tdf#90174 FILESAVE: export of bullet color for pptx"

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-05-11 19:43:25 UTC
PriyankaGaikwad committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c3b96790da88fb22b5e932f9a4abaeb330b610a

tdf#90174 FILESAVE: export of bullet color for pptx

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Akshay Anand 2015-05-14 07:08:01 UTC
Verified on LO build ID : 

Version: 5.0.0.0.alpha1+
Build ID: 847b4537928ff64cfdd6532704f7c48d947ac00f
TinderBox: Win-x86@42, Branch:master, Time: 2015-05-13_23:01:13
Locale: en-US (en_US)

This issue has been fixed.