Bug 90193 - Calc is slow with text wrapping after using font live preview
Summary: Calc is slow with text wrapping after using font live preview
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2015-03-24 10:28 UTC by skyphoton
Modified: 2020-06-07 15:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice Calc slowdowns after whole column "A" or "B" or "C" is selected in sheet IV_p2_U7-10 (372.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-03-24 10:28 UTC, skyphoton
Details
Lots of rows (40.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-04-19 08:32 UTC, mahfiaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description skyphoton 2015-03-24 10:28:43 UTC
Created attachment 114301 [details]
LibreOffice Calc slowdowns after whole column "A" or "B" or "C" is selected in sheet IV_p2_U7-10

LibreOffice Calc slowdowns after whole column "A" or "B" or "C" is selected. After you change the sheet it is okey but still slowdowns on the previus one.

Asus Eee PC 1015PE:
Intel(R) Atom(TM) CPU N570 @ 1.66GHz, 1666 MHz
Intel(R) Graphics Media Accelerator 3150
2Gb DDR3
Comment 1 m.a.riosv 2015-03-24 21:44:58 UTC
Hi @skyphoton, thanks for reporting.

Please, doing what, do you see the slowdown, after select the column?

And please don't set up as NEW when reporting, it's the usual here, than someone else confirm the bug and set up as NEW.
Comment 2 skyphoton 2015-03-25 00:11:17 UTC
(In reply to m.a.riosv from comment #1)
> Hi @skyphoton, thanks for reporting.
> 
> Please, doing what, do you see the slowdown, after select the column?
> 
> And please don't set up as NEW when reporting, it's the usual here, than
> someone else confirm the bug and set up as NEW.

Yes, after column selection. I want to hide column and at first I need to select it. But after selection whole column by clicking on its label ("B" for an example) it is hard to continue work of its freezing and CPU usage about 90%, cursor moves only every 3-5 seconds so I try to select another sheet (tab) and after another sheet (tab) is selected the slowdown stops but reopening previous sheet where column "B" was selected resumes freezing. 
Only closing and reopening entire document fix that. But every time I select whole column it repeats.
Comment 3 skyphoton 2015-03-26 10:46:38 UTC
Tools > Options > LibreOffice > View > Font Lists > Show preview of fonts.

Unchecking "Show preview of fonts" helps.
Comment 4 m.a.riosv 2015-07-18 02:17:53 UTC
Works fine for me with:
Win7x64
Version: 4.4.5.1 Build ID: 1b6df295803ea040dab1b48b5424da8d78d94cf0

No issue with "Show preview of fonts" checked.
Comment 5 mahfiaz 2016-04-19 08:14:05 UTC
Works for me as well in 5.1.2.1 on Linux.

How many fonts do you have installed? Which version of Windows?
Comment 6 mahfiaz 2016-04-19 08:32:10 UTC
Created attachment 124489 [details]
Lots of rows

Oh, I was able to reproduce it.

1) Open the attached file "Lots of rows", contains 2132x2 cells of English text with some formatting.
2) Ctrl+A to select everything
3) Click down the Font picker from the toolbar, move mouse over the font names so it previews you the text with different fonts. Don't pick anything.
4) Click on any cell or column to see how updating selection is slow. Repeat 3 if necessary.
Comment 7 mahfiaz 2016-04-19 08:43:42 UTC
Wrapping text option is what makes the difference. If wrapping is on (doesn't matter if it's direct formatting or from style), this slowdown happens.

After it has slowed down, select all and disable text wrapping and everything is fast again.
Comment 8 QA Administrators 2017-05-22 13:28:00 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2020-04-12 03:27:59 UTC Comment hidden (obsolete)
Comment 10 Roman Kuznetsov 2020-06-07 15:31:56 UTC
no repro in

Version: 7.1.0.0.alpha0+
Build ID: 2047a5978ac8188e61da9cd3b2f40d86df5570bb
CPU threads: 4; OS: Mac OS X 10.15.5; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

but possibly it's windows only
Comment 11 Roman Kuznetsov 2020-06-07 15:33:44 UTC
no repro in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 651844c9b122fd8463ad1dde4f9a0200efc345a3
Потоков ЦП: 4; ОС: Windows 10.0 Build 18363; Отрисовка ИП: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); ИП: ru-RU
Calc: threaded

so let's close it as WFM