Bug 90194 - Make Colibre the new default in Windows 10
Summary: Make Colibre the new default in Windows 10
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.1.0
Keywords: difficultyBeginner, easyHack, skillDesign
: 107377 (view as bug list)
Depends on:
Blocks: Icon-Themes
  Show dependency treegraph
 
Reported: 2015-03-24 10:59 UTC by Adolfo Jayme
Modified: 2018-03-30 19:50 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adolfo Jayme 2015-03-24 10:59:06 UTC
On one hand, Breeze fits OS X Yosemite’s (and iOS’) aesthetics much better than Sifr (bug 76681 comment 6); on the other, it is more in line with Windows 10 icons. Besides, I love the fact that it doesn’t drop color.

So: can we? Please? =)
Comment 1 Heiko Tietze 2015-03-24 12:15:25 UTC
The Breeze icons are very controversially discussed. IMHO it should be the default for KDE only.
Comment 2 V Stuart Foote 2015-03-24 13:01:03 UTC
For OS X, might do to survey that group of users to compare Sifr and Breeze side by side.

Agree, there is a case to be made for using Breeze on Windows 10, but so far too few preview users to take any reasonable measure.  Tango probably is the less disagreeable for other Windows Desktops.
Comment 3 Heiko Tietze 2015-03-24 13:42:22 UTC
Sifr: https://user-prompt.com/about-the-performance-of-the-sifr-icon-set/
Breeze: https://user-prompt.com/intermediate-results-of-the-icon-tests-breeze/

Resume: https://user-prompt.com/extracting-the-dna-of-icons/

(At the time of the survey the Breeze icon set was not known. And we didn't ask for the OS.)
Comment 4 Adolfo Jayme 2015-06-02 13:06:47 UTC
Now that Sifr falls back on Breeze, on OS X there is a horrible mixture of non-matching Sifr and Breeze icons all over the place.
Comment 6 Yousuf Philips (jay) (retired) 2015-06-10 21:24:01 UTC
Windows 10, like Windows 8, has a number of icons that are flat white icons on a color background, primarily in their metro ui and in their metro apps, but they havent changed their desktop app icons to flat or their file type icons to flat. So i doubt placing a flat dark icons set would be good without mandating that libreoffice's theme is white. MSO 2013 does this.

http://www.extremetech.com/wp-content/uploads/2014/10/windows-10-technical-preview-start-menu-live-tiles-full.jpg

http://theawesomer.com/photos/2014/10/windows_10_3.jpg
Comment 7 andreas_k 2015-06-21 18:18:56 UTC
I understand that the user-prompt survey for breeze was not that good BUT the difficult icons like save were changed because of the bad associations AND when you look galaxy and breeze than you won't see that difference because Uri and I were very conservative.

Overview off all icon sets (be careful it's the webserver of my company and you load 5.000 icons)
http://arsenalrace.at/analytics/ak/libreoffice/?folder=cmd_lc&root=galaxy

And when you look at the standard icons I look at each icon function and think what could match.

and when you don't be happy about an icon, fill a bug report.
Comment 8 Robinson Tryon (qubit) 2016-08-25 05:39:04 UTC Comment hidden (obsolete)
Comment 9 Heiko Tietze 2017-01-12 12:55:25 UTC
Design team talked about Breeze as default on Windows and decided against it because it fits not well into the system standard.
Comment 10 Adolfo Jayme 2017-01-12 17:37:06 UTC
Seriously? Never opened any UWP application?
Comment 11 steve -_- 2017-01-12 17:51:04 UTC
Yeah I was surprised as well and did not chime in or vote. What is UWP?
Comment 12 V Stuart Foote 2017-01-12 18:20:54 UTC
UWP -- https://en.wikipedia.org/wiki/Universal_Windows_Platform

For example Office 365 and the Outlook Web App have been implemented with UWP in mind. But rather than Breeze, Sifr would actually be the better choice for a changed default for Windows--just ensure it offers a full icon set to avoid fall-back to Breeze, though I think most of that was resolved. Provide color where needed, but mono-cromatic Sifr in general.

Regards this UX decision, personally I'm fine with retaining the Tango status quo on Windows builds so a +1 for the Wontfix here.
Comment 13 Adolfo Jayme 2017-04-25 14:01:19 UTC
*** Bug 107377 has been marked as a duplicate of this bug. ***
Comment 14 andreas_k 2018-03-09 11:10:49 UTC
I suggest to make colibre the new default for libreoffice Bug 115867
Comment 15 andreas_k 2018-03-09 11:11:24 UTC
For windows
Comment 16 V Stuart Foote 2018-03-09 13:37:01 UTC
OK, lets see how the new Colibre icon set merged for bug 115867 is received on master, toward adopting as default icons theme for Windows at 6.1 release.

Meanwhile should we seek ESC approval to add as late feature (but not yet a default) for 6.0, to increase exposure and uncover any holes in the set sooner? Or bundle as an extension immediately?
Comment 17 andreas_k 2018-03-09 13:43:34 UTC
I will make an extension when the Colibre icon theme is finished and upload it to the extension webpage. in paralell it would be nice to inform ESC to change the windows icon theme for 6.1.

So in a perfect world I will make a blog post about Colibre icons reference to the master build for testers and say that if someone like to use Colibre in 6.0 they can download Colibre Icons from the extension webpage.

But I know that I need some time to get feedback from everybody so today Colibre was added to master tomorrow I can download and test and in paralell I finalize the icon theme.

Maybe Jay will review Colibre icons to get propper feedback. I want a nice 6.1 release where Colibre is 100% finished and das good as possible reviewed.
Comment 18 Heiko Tietze 2018-03-20 10:34:21 UTC
(In reply to V Stuart Foote from comment #16)
> Meanwhile should we seek ESC approval to add as late feature...

(In reply to andreas_k from comment #17)
> ...in paralell it would be nice to inform ESC to
> change the windows icon theme for 6.1.

Don't see a change regarding the default for Windows under all the submissions https://gerrit.libreoffice.org/#/q/owner:%22andreas_kainz+%253Ckainz.a%2540gmail.com%253E%22
Comment 19 andreas_k 2018-03-20 10:39:28 UTC
When I get a go for it I'll submit a change. Now I finalize the icon theme.
Comment 20 Heiko Tietze 2018-03-20 10:41:32 UTC
(In reply to andreas_k from comment #19)
> When I get a go for it I'll submit a change. Now I finalize the icon theme.

Usually you commit to Gerrit and let others submit.
Comment 21 Tomaz Vajngerl 2018-03-20 12:32:32 UTC
Switching the default is the easiest of all. 

The icon theme is already in a good shape so what I wonder is if there is someone that would be against making it the default and why? Also as we don't support XP and Vista anymore I wonder if we should make it default for Windows 7 and newer too?
Comment 22 V Stuart Foote 2018-03-20 13:01:30 UTC
(In reply to Heiko Tietze from comment #18)
> (In reply to V Stuart Foote from comment #16)
> > Meanwhile should we seek ESC approval to add as late feature...
> 
> (In reply to andreas_k from comment #17)
> > ...in paralell it would be nice to inform ESC to
> > change the windows icon theme for 6.1.
> 
> Don't see a change regarding the default for Windows under all the
> submissions
> https://gerrit.libreoffice.org/#/q/owner:%22andreas_kainz+%253Ckainz.
> a%2540gmail.com%253E%22

We need ESC approval to backport to 6.0 to expose the new Windows 10 friendly icons (bug 115867) as a late feature. And with that, go ahead and make Colibre default for all Windows users on builds of master toward 6.1--it is fine on 8, 8.1 and 10 and just a little rough on Windows 7, but that is fine.
Comment 23 V Stuart Foote 2018-03-20 18:56:46 UTC
Removing B̶r̶e̶e̶z̶e̶ from the title. Colibre has been designed to be Windows theme friendly (bug 115867) and is a better solution for all supported Windows builds than Breeze/Sifr as replacement for Tango/Galaxy legacy default for Windows.
Comment 24 Heiko Tietze 2018-03-22 18:55:35 UTC
Design team and ESC welcomes this idea. Make Colibre the default for all Windows version, beginning with 6.1 alpha, and replace Galaxy as the ultimate fallback by it.
Comment 25 Heiko Tietze 2018-03-27 15:07:15 UTC
Patch at https://gerrit.libreoffice.org/#/c/51959/
Comment 26 Commit Notification 2018-03-28 16:30:03 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6d4bb4dd4ef425a429c929e7d953cf9b54a74576

tdf#90194 - Make Colibre the new default in Windows

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Heiko Tietze 2018-03-28 16:32:13 UTC
Patch changes the fallback default theme (which is used on Windows) to Colibre. Any further fallback solution, such as when an icon is missing, should go into another ticket. Patch would be ready to submit.
(That's also true for making Sifr the default on macOS and Elementary on Gnome - new tickets are required.)