Bug Hunting Session
Bug 90297 - LibreOffice Math dark theme > dark text and background
Summary: LibreOffice Math dark theme > dark text and background
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: accessibility
: 116585 (view as bug list)
Depends on:
Blocks: Formula-Editor UI-Theming
  Show dependency treegraph
 
Reported: 2015-03-28 14:56 UTC by Juraj
Modified: 2019-05-15 17:38 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Bux example in Writer (71.71 KB, image/png)
2015-03-28 14:56 UTC, Juraj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juraj 2015-03-28 14:56:08 UTC
Created attachment 114418 [details]
Bux example in Writer

the text input in math modul (in Writer and in Math..) is black and the text is black too
i am using the Dorian theme 3.10
http://killhellokitty.deviantart.com/art/Dorian-theme-3-10-416353853

when i change the document color the color in text input change too but i want dark document color and white input color in this box
and when i select text in this box the selection is white and text is white too

is there way to change only the text input color in this box??
Comment 1 Adolfo Jayme 2015-03-29 13:35:04 UTC
Thank you for your bug report.
Comment 2 QA Administrators 2016-09-20 10:14:15 UTC Comment hidden (obsolete)
Comment 3 Adam Maćkowiak 2016-10-09 19:55:02 UTC
Hi!

I can confirm that this bug occurs on LO 5.2.2 from libreoffice PPA on Kubuntu 16.04.1 LTS amd64. I'm using dark breeze theme. I set VCL_ICONS_FOR_DARK_THEME=1 and SAL_USE_VCLPLUGIN=gtk variables to make LO look good with my theme.

Also, I found workaround to set Tools → Options → Application Colors → Font color to White. This solves problem with dark font in LO Math but I hadn't check if it breaks application look in another place.
Comment 4 Paul Rozdeba 2017-05-16 01:00:30 UTC
I can confirm that this bug still exists in LO 5.3.3.2, using the dark Adwaita theme in GNOME.  The text input background for the Formula editor in LO Writer is dark gray and the text is black, making it almost impossible to read.
Comment 5 Severo Raz 2018-01-20 13:52:37 UTC
Can confirm for LO 5.3.7.2.0+ under GNOME 3.26.2-1.
Comment 6 Xisco Faulí 2018-01-21 17:15:05 UTC
(In reply to Severo Raz from comment #5)
> Can confirm for LO 5.3.7.2.0+ under GNOME 3.26.2-1.

Is it the case with LibreOffice 6.0 as well?
Comment 7 Severo Raz 2018-03-17 12:28:09 UTC
Yes, just tested it with 6.0.2.1.0.
Comment 8 Gabriel 2018-05-24 11:35:03 UTC
Same problem with Libreoffice 6.0.3 and GTK 3.22.30.
Comment 9 Ville Aakko 2019-05-10 06:25:07 UTC
Still problem in 6.2.3.2.

Using Arch Linux, libreoffice-fresh. This is on KDE5, gtk3 3.24.8. I have been playing with various alternatives for SAL_USE_VCLPLUGIN, such as gtk, gtk3, kde5.  All exhibit the same behavior.

Moreover, overriding text color as suggested in comment #3, also changes color in other places, too, such as the document page, which is still white. It is impossible to find a single color which would have good enough contrast to be comfortably readable in all places.
Comment 10 Buovjaga 2019-05-10 06:43:33 UTC
*** Bug 116585 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2019-05-14 01:24:51 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ea191cf9807d0b0725fbc4831053a26ba71c2328%5E%21

tdf#90297 use field colors for math's edit engine

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-05-15 17:38:41 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f9c94cfdde6c0af621cf80467a9d83c789699093%5E%21

tdf#90297 set default SmEditWindow background

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.