Bug 90346 - CALC Crashs by mess of unconditional formatting
Summary: CALC Crashs by mess of unconditional formatting
Status: RESOLVED DUPLICATE of bug 80768
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-30 10:51 UTC by bonbon
Modified: 2015-03-31 11:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bonbon 2015-03-30 10:51:04 UTC
When we set a conditional formatting suck like "B2:B200   value >2500", then if I edit more steps such like drag to fill some cells...etc, or others... 
then my conditional formatting will change to be something like this:
B2                                    >2500
B13:B16                               >2500
B64:B66;B59:B61                       >2500
...
...
...
...
...
...
...
...
...

more steps editted, more formatting will appear automatically, and finally the unconditional formatting editor appears in a big mess.
I thought although the uncdonditional formatting editor now is very dificult to see in order, but cells´ value in the workshee of calc are still correct. So I just let it be.

However disaster comes soon, one day I just find the worksheet goes very very very slowly and crashs till I can not use it any more. I think maybe it´s caused by the mess of unconditional formatting. So I start to organize hundreds of unconditional formattings that produced by calc automatically, now it´s only this one again in my unconditonal formatting editor like "B2:B200         value>2500", and this worksheet comes back to go fast again.

My libreoffice Version is 4.4.1.2. I hope this bug could be fixed as soon as possible. Best wishs!
Comment 1 m.a.riosv 2015-03-30 23:16:57 UTC
You are right @Kevin, some request about this matter.

https://bugs.documentfoundation.org/show_bug.cgi?id=87274

You have reported another bug about this, I think.
https://bugs.documentfoundation.org/show_bug.cgi?id=80768

*** This bug has been marked as a duplicate of bug 80768 ***
Comment 2 bonbon 2015-03-31 11:10:41 UTC
ah.yes. But I´m keep upgrading versions of LO and till today it´s not solved yet.:(
Comment 3 m.a.riosv 2015-03-31 11:57:54 UTC
But having the oldest version with the issue is how it must be. No duplicates for every version.

So please add a comment in the original bug indicating the version in what the bug remains unsolved, but without modify the version of the report.

I know it's annoying. Seems Markus have been working with conditional format on the last days, but I don't know if it really solves this issue.
https://gerrit.libreoffice.org/gitweb?p=core.git;a=shortlog;h=refs/heads/private/moggi/conditional-format-api-rebased

*** This bug has been marked as a duplicate of bug 80768 ***