Download it now!
Bug 90390 - Problems with umlauts
Summary: Problems with umlauts
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.6.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2015-04-01 10:52 UTC by Joerg Brunsmann
Modified: 2017-09-01 20:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Picture of Umlaute-Problem (39.36 KB, image/tiff)
2015-04-01 10:52 UTC, Joerg Brunsmann
Details
Crash Report (40.74 KB, application/vnd.oasis.opendocument.text)
2015-04-13 20:49 UTC, Joerg Brunsmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Brunsmann 2015-04-01 10:52:25 UTC
Created attachment 114520 [details]
Picture of Umlaute-Problem

I recognized a strange error in writer.
When I type my first name (Jörg), directly after starting writer, the programm types "öJrg" - seems there is a "problem" with german Umlaute, the "ö" is printed first, although i type it after the "J".
This only happenes if an Umlaut (Ä,Ö,Ü) is the second letter i type. And only, after the program was started freshly and i created a new textfile.
Must be an error deep in the code - Open Office (even the old versions before Apache Open Office) behave the same way...
Comment 1 Alex Thurgood 2015-04-01 17:31:34 UTC
Can not confirm on

Version: 4.5.0.0.alpha0+
Build ID: 09f83e1f409853a6c6e4300287c4e50bad5b9d0b
Locale: fr_

with Azerty Mac bluetooth keyboard, but this probably requires a German locale and German keyboard to reproduce, as my umlauts are combinations of the ¨ key plus a/e/o/u.
Comment 2 A (Andy) 2015-04-02 20:57:30 UTC
For me not reproducible with LO 4.4.1.2, Win 8.1
Comment 3 Buovjaga 2015-04-11 09:43:04 UTC
Which version of OS X?
It sounds somehow specific to your system as even OpenOffice exhibits the same behavior.

Maybe you could still try this: https://wiki.documentfoundation.org/User_Profile#Resolving_corruption_in_the_user_profile

And also try with the latest version of LibO, 4.4.2.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided more information & results.
Comment 4 Joerg Brunsmann 2015-04-12 09:46:58 UTC
OSX Version on the iMac ist 10.10.3 but the error also appears on my iBook, which is running on OXS 10.9.5.
Comment 5 Joerg Brunsmann 2015-04-12 09:48:30 UTC
Build ID ist d50a87b2e514536ed401c18000dad4660b6a169e
with german language pack
Comment 6 steve -_- 2015-04-12 15:44:39 UTC
Joerg could you download and test 4.4.2 please?
https://www.libreoffice.org/download/libreoffice-fresh/

10.10.3 + Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: de_

can't reproduce.
Comment 7 Joerg Brunsmann 2015-04-13 20:49:32 UTC
Created attachment 114767 [details]
Crash Report

Just tried it... sorry, still the same problem.

found out something more:
I must write my name (Jörg) quite quick. Typing slow makes the error not to appear.

when i try to reproduce the error with other umlauts i recognized something strange - the error appears also with "ä" and "ü" (wanting to type "Jürg" becomes "Üjrg"; "Järg" becomes "Äjrg").
When I use the "ß" (wanting to type "Jßrg") LO crashes....
I think i can see, how the letters a changes (from Jßrg to ßjrg), then the program crashes.
Maybe thats a hint... ?!?
Comment 8 Joerg Brunsmann 2015-04-13 20:56:53 UTC
and another import detail: LO crashes only, when I quickly type space or type the return key after "Jßrg".
Could this be a hint for problem in the spell checker or the Auto-Correct-feature??
Comment 9 QA Administrators 2015-10-14 19:51:11 UTC Comment hidden (obsolete, spam)
Comment 10 Markus Grob 2016-04-08 22:33:02 UTC
Could not be verified and no additional info was given.
Comment 11 Peter Chastain 2016-04-18 11:40:08 UTC
I can confirm this bug is present in both current and master.

Steps to reproduce:
1) Set keyboard to German layout "System Preferences->Keyboard->Input Sources->Add(+)".
2) Launch LibreOffice.
3) Click "Create: Writer Document".
4) Quickly type at least 2 characters with the 2nd being an umlaut-accented character.
The accented character will appear first, not second.

This only occurs with a newly-launched app and new Writer document. I've tested against other OS X text editor apps (TextEdit, CotEditor) without error; this bug appears exclusive to LO.

Master =
Version: 5.2.0.0.alpha0+
Build ID: ac488ccba124fc2539f765d354a0b97c9b843f51
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-03-22_04:19:45
Locale: en-US (en.UTF-8)

Current =
Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default; 
Locale: en-US (en.UTF-8)
Comment 12 QA Administrators 2017-05-22 13:22:48 UTC Comment hidden (obsolete, spam)
Comment 13 eisa01 2017-09-01 20:48:40 UTC
Seems to be fixed for me. Can type Jörg without problems in a new document

Version: 6.0.0.0.alpha0+
Build ID: 2b78b9feab9521e614b9edae17709cb6e2001292
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-08-25_05:47:15
Locale: en-US (en_US.UTF-8); Calc: group