Bug 90403 - PPTX: table width is not imported correctly
Summary: PPTX: table width is not imported correctly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Andras Timar
QA Contact:
URL:
Whiteboard: target:5.0.0 target:4.3.7 target:4.4.3
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-01 20:43 UTC by Andras Timar
Modified: 2015-04-13 10:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc (PPTX) (37.76 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-04-01 20:43 UTC, Andras Timar
Details
reference rendering (MS Office 2010) (3.06 KB, application/pdf)
2015-04-01 20:44 UTC, Andras Timar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-04-01 20:43:33 UTC
Created attachment 114536 [details]
bugdoc (PPTX)

The attached PPXT looks different in Impress than in PowerPoint. If I save it from PowerPoint 2010, then Impress opens it correctly. 

The relevant difference between the two documents was the following (the bounding box of the table):

Wrong:
<a:ext cx="3000000" cy="3000000">

Good:
a:ext cx="9001000" cy="1483360"/>

9001000 equals the sum of a:gridCol w values of the table.
Comment 1 Andras Timar 2015-04-01 20:44:02 UTC
Created attachment 114537 [details]
reference rendering (MS Office 2010)
Comment 2 raal 2015-04-02 13:26:21 UTC
I can confirm with LO 4.4.1.2, win7
Comment 3 Commit Notification 2015-04-03 06:46:03 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=037fe3671cbdad51f52d2f69f72f47f463dba7c2

tdf#90403 PPTX import: use real table size

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2015-04-09 23:25:16 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6322ef95c9d3128ede01d45f1542c6ad03cac392&h=libreoffice-4-3

tdf#90403 PPTX import: use real table size

It will be available in 4.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-04-12 20:14:54 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=266b593d1b7b30003aefc311e1635fcd721a71aa&h=libreoffice-4-4

tdf#90403 PPTX import: use real table size

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Timur 2015-04-13 10:45:49 UTC
Version was set as 4.4.1.2 but looks like Inherited to me, so I change.