Download it now!
Bug 90436 - UI with PDF Export, the dialog PDF Options, tab General, should mention "Selection/Selected sheet(s)"
Summary: UI with PDF Export, the dialog PDF Options, tab General, should mention "Sele...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.4.0
Keywords: filter:pdf, needsDevEval
: 106624 (view as bug list)
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2015-04-03 15:41 UTC by Cor Nouws
Modified: 2017-11-05 21:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
5400alpha0 screen shots (90.42 KB, application/vnd.oasis.opendocument.text)
2017-02-08 11:52 UTC, brucehohl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2015-04-03 15:41:12 UTC
Use a document with more pages
e.g https://bugs.documentfoundation.org/attachment.cgi?id=114587

Select 2nd page

File > Print preview
  > Shows page 2
File > Export as PDF
  > Exports all pages
In the dialog PDF options, one can set Export page # (after counting..)

As far as I can see, this has always been like this?
Comment 1 Cor Nouws 2015-04-03 15:42:22 UTC
prolly easy hack ??
Comment 2 m.a.riosv 2015-04-03 19:10:48 UTC
Hi Cor,

With 4.4.2 there is a "Selection" option that seems to work fine, only one page. That option is there at least from 3.6
Comment 3 Cor Nouws 2015-04-03 21:41:17 UTC
Hi migual,

(In reply to m.a.riosv from comment #2)

> With 4.4.2 there is a "Selection" option that seems to work fine, only one
> page. That option is there at least from 3.6

Hurray :)
Stupid that I didn't realist that and that the UI does not suggest it..
I only use that when I have a selection of cells!

The option is there already in 3.3.0 too.
Comment 4 Cor Nouws 2015-04-03 21:43:06 UTC
Let's make an appropriate enhancement of this.
Comment 5 m.a.riosv 2015-04-03 23:29:43 UTC
Hi Cor,

then perhaps it's better change the status to 'enhancement' accordingly, and the UI in cc.

You are right it's not too much clear only 'Selection', I think better being more similar than in 'Print'.
Comment 6 Cor Nouws 2015-04-04 11:03:24 UTC
(In reply to m.a.riosv from comment #5)
> then perhaps it's better change the status to 'enhancement' accordingly, and
> the UI in cc.

Yes, I intended to do that.
Comment 7 Robinson Tryon (qubit) 2015-12-13 11:21:38 UTC Comment hidden (obsolete)
Comment 8 Timur 2016-01-14 08:23:03 UTC
This seems like a really small task, yet it takes too long.
Comment 9 Commit Notification 2016-10-14 06:47:17 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=44a02cc81d8a23f19655ae9f67ff69bdfe683df9

Better wording in UI for in case of PDF export from Calc - tdf#90436

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-10-14 06:57:03 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e1118f1b940df9a2504a63823f93b1e609daa97c

Revert "Better wording in UI for in case of PDF export from Calc - tdf#90436"

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 brucehohl 2016-11-02 01:25:11 UTC
Bug 54052 suggests another way to address the inconsistency in Calc that 'File > Export as PDF' creates a PDF of the entire workbook by default yet 'File > Print' sends to the printer the selected sheets by default. This inconsistency is somewhat annoying and unexpected.
Comment 12 Cor Nouws 2017-02-06 16:49:39 UTC
(In reply to brucehohl from comment #11)
> Bug 54052 suggests another way to address the inconsistency in Calc that

I can't read that per see from that issue. It looks as if the scope is much wider (wish for more options to set as default).

> 'File > Export as PDF' creates a PDF of the entire workbook by default yet
> 'File > Print' sends to the printer the selected sheets by default. This
> inconsistency is somewhat annoying and unexpected.

Options > Calc > Print now has "[] Print only selected sheets"
and I guess the idea is to have the same option for PDF export, but then on page ... ?

Could you/* please file a separate issue for that?
Comment 13 brucehohl 2017-02-07 02:45:51 UTC
In Writer the "File > Print" default is "Y = All Pages" and the "File > Export" default is "Y = All".  So the user gets the SAME default output for printing or PDF creation.

In Calc the "File > Print" default is "Y = Selected Sheets" and the "File > Export as PDF" default is "Y = All".  So in Calc the user gets DIFFERENT default output for printing versus PDF creation.

This inconsistency (and annoyance) could be resolved if for Calc the "File > Export as PDF" default were changed to "Y = Selection" (The default for a spreadsheet should be 'selection' not 'all' because spreadsheets can easily contain hundreds of pages of data that would never be printed or exported to PDF.)

Perhaps this change would cover the reasons for this enhancement request.  And if enhancement request 54052 was filed in part to allow the user to get Print & PDF creation defaults in sync then it would be partially satisfied.  Thoughts?
Comment 14 Cor Nouws 2017-02-07 06:43:10 UTC
(In reply to brucehohl from comment #13)

> ...(The default for a
> spreadsheet should be 'selection' not 'all' because spreadsheets can easily
> contain hundreds of pages of data that would never be printed or exported to
> PDF.)

The default All in PDF export is the (print range) on the current sheet.
To include all sheets, you must select them and choose Selection/Selected sheet(s) in the PDF options.
So in that aspect a totally different approach from the print dialog.
Comment 15 Cor Nouws 2017-02-07 07:30:49 UTC
(In reply to Cor Nouws from comment #14)

> The default All in PDF export is the (print range) on the current sheet.

So on PDF export that label should maybe also change from "All" to "Current sheet"?!
Comment 16 Commit Notification 2017-02-07 11:38:13 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae1b9d55ee62e904ecc52359f536b9b5966174bd

tdf#90436 - better wording for selection in case of PDF export from Calc

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Cor Nouws 2017-02-07 13:50:04 UTC
(In reply to Commit Notification from comment #16)
> Cor Nouws committed a patch related to this issue.
> It has been pushed to "master":

Thanks a lot for you help, bubli!
Comment 18 m.a.riosv 2017-02-07 15:25:12 UTC
Thanks a lot for both, nice to have this enhancement. One of those that makes life pleasant. I'll test when available in master.

Meanwhile seems appropriated change to Resolved - Fixed.
Comment 19 Cor Nouws 2017-02-07 16:24:45 UTC
(In reply to m.a.riosv from comment #18)
> Thanks a lot for both, nice to have this enhancement. One of those that
> makes life pleasant. I'll test when available in master.


thanks Miguel - what is your take on comment #15 ?
Comment 20 m.a.riosv 2017-02-07 23:41:05 UTC
Fine. (I guess also changing the behaviour)
Comment 21 Cor Nouws 2017-02-08 09:01:20 UTC
(In reply to m.a.riosv from comment #20)
> .. I guess also changing the behaviour

OK.. how ?
Comment 22 brucehohl 2017-02-08 11:52:59 UTC
Created attachment 131010 [details]
5400alpha0 screen shots

Comment 1:
> The default All in PDF export is the (print range) on the current sheet.
> To include all sheets, you must select them and choose Selection/Selected 
> sheet(s) in the PDF options.
> So in that aspect a totally different approach from the print dialog.
In my use of previous LO versions and my test of LO-5400alpha1 "File > Export as PDF" where Y = All exports all sheets and honors any print ranges. This behavior is the same as "File > Print" where Y = All sheets.

Comment 2: 
With reference to this version from late yesterday (see screen shots):
Version: 5.4.0.0.alpha0+  Build ID: 653e181fb831a04c2845d99f79f72454a88bb948
"File > Export as PDF", "Selection" has been changed to "Selected sheet(s)", however, that is an incomplete description as this feature can also export only selected cells.  I think the bug title suggested using "Selection/Selected sheet(s)" which would be more clear but might change the size of the "PDF Options" window.

Comment 3:
As mentioned in my comment 13 I still think Calc's "File > Export as PDF" should mirror Calc's "File > Print" both in default (Selected sheets).  Ideally, in choices as well, which suggests "Export as PDF" should include these choices: All sheets, Selected sheets, Selected cells, All pages, and Pages.  This would provide the most consistent (& least annoying) user experience IMHO :)
Comment 23 Cor Nouws 2017-02-08 12:16:35 UTC
(In reply to brucehohl from comment #22)

> In my use of previous LO versions and my test of LO-5400alpha1 "File >
> Export as PDF" where Y = All exports all sheets and honors any print ranges.
> This behavior is the same as "File > Print" where Y = All sheets.

OK, maybe I remember this wrong.

> Comment 2: 
> With reference to this version from late yesterday (see screen shots):
> ..

Yes, it should be Selection/Selected sheets. Did notice, but forgot to improve in the patch. Send a new one.

> Comment 3:
> As mentioned in my comment 13 I still think Calc's "File > Export as PDF"
> should mirror Calc's "File > Print" both in default (Selected sheets). 
> Ideally, in choices as well, which suggests "Export as PDF" should include
> these choices: All sheets, Selected sheets, Selected cells, All pages, and
> Pages.  This would provide the most consistent (& least annoying) user
> experience IMHO :)

No objection as such. Please file a new issue.
Comment 24 m.a.riosv 2017-03-18 16:34:59 UTC
*** Bug 106624 has been marked as a duplicate of this bug. ***
Comment 25 Commit Notification 2017-05-15 14:12:37 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02cf5ad31794a628a10fddc9fb538fd4e48a6e64

tdf#90436 - correct label = Selection/Selected sheet(s)

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Timur 2017-05-17 17:45:31 UTC
Best fix is own fix :)

I agree on a general principle that "File > Export as PDF" should mirror "File > Print". I submitted some bugs for Mail Merge on this myself. And it would require separate bug, if doesn't exist, as Cor said. 

But what's related here is now just this: 
"File > Print -> Selected sheets" could be renamed to "Selection/Selected sheet(s)" to be consistent with "Export as PDF".
Comment 27 Xisco Faulí 2017-11-05 16:25:41 UTC
A polite ping to Cor Nouws: is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks
Comment 28 Cor Nouws 2017-11-05 21:07:47 UTC
indeed OK now.