Bug Hunting Session
Bug 90437 - Very bad view: toolbars and items are black in KDE 4
Summary: Very bad view: toolbars and items are black in KDE 4
Status: RESOLVED DUPLICATE of bug 89613
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 91606 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-03 15:50 UTC by Ysabeau
Modified: 2015-07-07 17:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of Writer showing the views. (387.71 KB, application/pdf)
2015-04-03 15:50 UTC, Ysabeau
Details
Screenshots of LibreOffice showing that it is useless (193.16 KB, image/jpeg)
2015-04-03 19:02 UTC, Ysabeau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ysabeau 2015-04-03 15:50:20 UTC
Created attachment 114588 [details]
Screenshots of Writer showing the views.

Very bad view for LibreOffice: toolbars are black, selected items are black, there are other various problems and we can't read what it is written. See the file for more information.

OS: Linux Fedora
Harware:
Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6310] 
model name      : AMD E-350 Processor 
cpu MHz         : 1600.000 
model name      : AMD E-350 Processor 
cpu MHz         : 1600.000 
  dimensions:    1600x900 pixels (423x238 millimeters) 
  depth of root window:    24 planes 
direct rendering: Yes 
server glx vendor string: ATI 
server glx version string: 1.4
Comment 1 m.a.riosv 2015-04-03 18:54:22 UTC
Hi @ Ysabeau, thanks for reporting.

Please try with the options in:

Menu/Tools/LibreOffice/Accesibility/Options for high contrast appearance.

If it doesn't work, please try resetting the user profile.
https://wiki.documentfoundation.org/UserProfile
Comment 2 Ysabeau 2015-04-03 19:02:35 UTC
Created attachment 114592 [details]
Screenshots of LibreOffice showing that it is useless
Comment 3 Ysabeau 2015-04-03 19:07:49 UTC
(In reply to m.a.riosv from comment #1)
> Hi @ Ysabeau, thanks for reporting.
> 
> Please try with the options in:
> 
> Menu/Tools/LibreOffice/Accesibility/Options for high contrast appearance.
> 
> If it doesn't work, please try resetting the user profile.
> https://wiki.documentfoundation.org/UserProfile

Thank you but... *all* has been made *before*. It is a result of a topic on fr-qa not only my poor little brain that decided to report. We suggest that to the person that has the problem, and he did it.

Another points: how can we read what is hidden by the black rectangle (see the second file that I added in the previous comment).
Comment 4 Julien Nabet 2015-04-03 21:26:30 UTC
Could you try to disable "hardware acceleration"? (Menu Tools/options/View, uncheck "Use hardware acceleration" in "Graphics Output".

If it still fails, could you also try to disable OpenCL? (Menu Tools/options/OpenCL, uncheck "Allow use of OpenCL")

Since it's unconfirmed + not a crash, let's lower importance.
Comment 5 m.a.riosv 2015-04-03 23:19:24 UTC
(In reply to Ysabeau from comment #3)
> (In reply to m.a.riosv from comment #1)

> Thank you but... *all* has been made *before*. It is a result of a topic on
> fr-qa not only my poor little brain that decided to report. We suggest that
> to the person that has the problem, and he did it.
I can't see in your report nothing about what have been done before.
OTHO sorry but we don't need the comments about your brain, at least me.
> 
> Another points: how can we read what is hidden by the black rectangle (see
> the second file that I added in the previous comment).
In your screenshot 'list box selections' are in black, the options I have mentioned are 'check box' options visible in your screenshot.
Comment 6 Adolfo Jayme 2015-04-04 06:26:16 UTC
(In reply to Julien Nabet from comment #4)
> If it still fails, could you also try to disable OpenCL? (Menu
> Tools/options/OpenCL, uncheck "Allow use of OpenCL")

Let’s not confuse OpenCL and OpenGL. The former has nothing to do with graphics output.
Comment 7 bougler 2015-04-04 06:29:43 UTC
I 4.3.5.2 and 4.4.2.2 in parallel.
The problem appears only on version 4.4 and has appeared in the first version 4.4
Thank you
(Machine translation)
Gérard
Comment 8 Jean-Baptiste Faure 2015-04-06 14:33:48 UTC
Thank you Ysabeau for the bug report. I do reproduce this bug myself but the screen copies already discussed on the qa-fr mailing list are clear. There is something that does not work as expected. So setting the status to NEW.

Best regards. JBF
Comment 9 Alex Thurgood 2015-04-07 13:41:38 UTC
Isn't this a duplicate of bug 89873 ?
Comment 10 Jean-Baptiste Faure 2015-04-07 18:04:06 UTC
(In reply to Alex Thurgood from comment #9)
> Isn't this a duplicate of bug 89873 ?

I do not think so because bug 89873 refers to the master while this one is for 4.4.

We obtained a new information about this bug: it seems to concern only KDE 4 window manager, no problem when the user switches to Gnome or Xfce. It works well with KDE 5 too.

Best regards. JBF
Comment 11 Jean-Baptiste Faure 2015-05-25 15:26:22 UTC
(In reply to Jean-Baptiste Faure from comment #8)
> Thank you Ysabeau for the bug report. I do reproduce this bug myself but the
> screen copies 

Sorry: I do _not_ reproduce this bug myself...

Best regards. JBF
Comment 12 Jean-Baptiste Faure 2015-05-25 15:28:12 UTC
*** Bug 91606 has been marked as a duplicate of this bug. ***
Comment 13 Julien Nabet 2015-05-25 16:06:05 UTC
Sorry for the confusion about OpenCL and OpenGL but could you, as indicated in my previous comment, try to disable "hardware acceleration"? (Menu Tools/options/View, uncheck "Use hardware acceleration" in "Graphics Output".

Also, what's your graphic card brand and model?
Are the graphic cards drivers updated?
Comment 14 bougler 2015-06-12 19:41:31 UTC
it is the libvclplug_kdelo.so package kde-integration that seems to cause.
For version 4.5 and 5.0, replace it with version 4.3 solves most of the problems
machine translation
Gérard
Comment 15 Maxim Monastirsky 2015-07-07 17:02:43 UTC

*** This bug has been marked as a duplicate of bug 89613 ***