Bug 90518 - EDITING: Cannot delete tables
Summary: EDITING: Cannot delete tables
Status: RESOLVED DUPLICATE of bug 78326
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-08 13:52 UTC by Johnny
Modified: 2018-02-01 00:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny 2015-04-08 13:52:42 UTC
Can create a table, but once created it cannot be deleted by selecting the table and hitting DEL. The only way to get rid of it is to click UNDO until the table goes (if possible at that stage any more). Previously I noticed this problem with Impress 4.4.1.2 as well.
Comment 1 Johnny 2015-04-08 13:59:17 UTC
Observed in versions 4.4.1.2 & 4.4.2.2
Comment 2 m.a.riosv 2015-04-08 14:56:27 UTC
Hi Johnny, thanks for reporting.

Reproducible with:
Win7x64
Version: 4.4.2.2 Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6

Works fine for me with:
Win7x64
Version: 4.5.0.0.alpha0+ (x64) Build ID: 2bbce7dcd46e8aca716808602aa152ecd85b42af
Comment 3 A (Andy) 2015-04-09 18:29:41 UTC
Reproducible with LO 4.4.1.2, Win 8.1

If one have inserted a table in IMPRESS the focus is on the table (see the blue squares at the frame/corners).  But if you press the Delete key nothing happens.  If you click with the mouse cursor on any place in the slide (-> the table is no longer focused) and then click with the mouse cursor on the border of the table (when the cursor has changed to a rectile) then the focus is back and you can delete the table with the Delete key.  To get the focus on the table is not very easy and user-friendly.
Comment 4 QA Administrators 2016-09-20 10:12:08 UTC Comment hidden (obsolete)
Comment 5 m.a.riosv 2016-09-21 23:08:53 UTC
Reproducible.
Win10x64
Version: 5.2.2.1 (x64)
Build ID: 3c2231d4aa4c68281f28ad35a100c092cff84f5d
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: es-ES (es_ES); Calc: group
Comment 6 jebsolutions 2016-10-22 02:41:08 UTC
Reproducible with Libreoffice 4.3.0 alpha 1
Windows 10 64 bit

Just a couple of weird related notes.  When you attempt to delete the table it does delete all the text inside the table.  But the table itself is still there.

At this point if you go to the Edit menu it will incorrectly have an option "Undo delete table".  If you select this it will restore the text in the table.

Work around: Insert a rectangle.  Shift-click the rectangle and the table to select both of them.  Hit the delete key.  Both are deleted.  No idea why this works, but just deleting the table doesn't.

Weird #2
--------
Select the whole table.  Control-C to copy it to the clip board.  Create a new slide.  Control-v will paste in the new table.  

But...if you press control-X to your new table what happens?  The table is not deleted.  Sometimes the table vanishes from the mini-preview of the slide on the left!  Even though it's still actually on the slide (?)  At this point if you go to the Edit menu at the top you may see "Undo insert object" -- note that it says object and not table.  If you select this it may delete the table.  This part is not consistent.  If I insert a new slide and paste again it might happen.
Comment 7 Mark Hung 2017-03-02 16:16:48 UTC
In 4.0.0.3, creating new table or select table do not select all the cells inside the table. Remedy to this for users is to move cursor to one of the cells first, then click the table border, then press DEL to delete the table.
Comment 8 Buovjaga 2017-05-07 16:16:34 UTC
*** Bug 107672 has been marked as a duplicate of this bug. ***
Comment 9 Buovjaga 2017-05-07 16:17:01 UTC
(In reply to Buovjaga from comment #8)
> *** Bug 107672 has been marked as a duplicate of this bug. ***

Comment from the bug:
If I select an additional object/element on the slide, however, and then press the Delete key - both elements get properly deleted. This is an additional inconsistency. It does not make sense that adding _more_ elements to a selection causes _less_ elements to remain from that selection after a keypress.
Comment 10 Aron Budea 2018-02-01 00:57:16 UTC

*** This bug has been marked as a duplicate of bug 78326 ***