Download it now!
Bug 90584 - CONTEXT MENU: Right-clicking on glue point doesnt have option to remove it
Summary: CONTEXT MENU: Right-clicking on glue point doesnt have option to remove it
Status: RESOLVED DUPLICATE of bug 45864
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu Connectors
  Show dependency treegraph
 
Reported: 2015-04-12 22:13 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-05-03 15:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot right click no option to remove glue point (154.34 KB, image/png)
2015-04-13 15:06 UTC, Gabriel Diosan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-04-12 22:13:21 UTC
Steps:
1) Open Draw
2) Draw a shape
3) Turn on glue points (Edit > Glue Points)
4) Insert a glue point onto the shape
5) Right-click the glue point

Version: 4.5.0.0.alpha0+
Build ID: b024e36ddb3b53163d7a01f6f7b5aadb7a858cd9
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-03-31_08:18:46
Comment 1 Gabriel Diosan 2015-04-13 15:05:50 UTC
Tested with:

LibreOffice 4.4.2 (Ubuntu 15.04 repo)

LibreOffice Version: 4.5.0.0.alpha0+
Build ID: b024e36ddb3b53163d7a01f6f7b5aadb7a858cd9
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-03-31_09:12:20
Locale: en_AU

LibreOffice 3.5.0 Build ID: d6cde02

No option in right-click menu to remove inserted glue points. Using keyboard delete key works however.

Changing this from UNCONFIRMED to NEW. 

Jay, do we need to put a UX Advice tag on this bug?

Gabriel
Comment 2 Gabriel Diosan 2015-04-13 15:06:28 UTC
Created attachment 114762 [details]
Screenshot right click no option to remove glue point
Comment 3 Yousuf Philips (jay) (retired) 2015-04-13 19:17:47 UTC
(In reply to Gabriel Diosan from comment #1)
> No option in right-click menu to remove inserted glue points. Using keyboard
> delete key works however.

Yep, when i didnt find it context menu, and there is no delete button in the gluepoints toolbar, the delete key was the only other possible way i could think of removing it.

The entire context menu is just a repetition of all the buttons in the gluepoints toolbar, which doesnt really make any sense as clicking the glue points button in the drawing toolbar, or Edit > Glue Points, will opens the gluepoints toolbar in order to make the changes, so why need it in the context menu. I guess the only reason, is for users who decide to disable the toolbar from popping up.

> Jay, do we need to put a UX Advice tag on this bug?

Well its always good to have other people's opinions, so lets CC them.
Comment 4 Heiko Tietze 2016-05-03 15:39:22 UTC
Closing this as duplicate of #45864 and adding blocks 86349 there.

*** This bug has been marked as a duplicate of bug 45864 ***