Download it now!
Bug 90626 - FILESAVE: Bullets enlarged when saved as PPTX
Summary: FILESAVE: Bullets enlarged when saved as PPTX
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Paul Trojahn
URL:
Whiteboard: target:6.1.0
Keywords: filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2015-04-15 08:10 UTC by Luke
Modified: 2017-12-30 16:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODP with bullets (11.67 KB, application/vnd.oasis.opendocument.presentation)
2015-04-15 08:10 UTC, Luke
Details
File saved as PPTX (32.91 KB, application/vnd.ms-powerpoint.12)
2015-04-15 08:14 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-04-15 08:10:20 UTC
Created attachment 114799 [details]
Sample ODP with bullets

Steps to reproduce the bug:

1) Open a new presentation in impress.
2) Click on format from the menu bar.
3) Select Bullet and Numbering from the drop down.
4) Select the image tab and select the type of bullet you want.
5) Click OK.
6) Type any text following the bullet.
7) Press Enter.
8) Save the file with .pptx extension.
10) Reopen the saved file in Impress or PowerPoint

Expected results:
Bullets say same size

Actual results:
New bullets are HUGE in both Impress and PowerPoint
Comment 1 Luke 2015-04-15 08:14:08 UTC
Created attachment 114800 [details]
File saved as PPTX
Comment 2 raal 2015-04-15 17:00:28 UTC
I can confirm with Version: 4.5.0.0.alpha0+
Build ID: 51e0d789c344547956764c3b5f0ef5a304f4e0aa
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-13_16:58:45
Comment 3 Timur 2015-10-13 15:40:24 UTC
I was free to add Mark to CC due to what he did in Bug 80520.
Comment 4 QA Administrators 2017-01-03 19:35:19 UTC Comment hidden (obsolete)
Comment 5 Luke 2017-01-04 02:41:46 UTC
Still exporting overly scaled bullets in  Version: 5.4.0.0.alpha0+ (x64)
Build ID: bf80bbb7b75febc2769d6b64e6981224982f8fe2
Comment 6 Commit Notification 2017-12-18 14:47:58 UTC
Paul Trojahn committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b4f14f4da046dab25362114db737968634cd720

tdf#90626 PPTX: Fix image bullet size

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Luke 2017-12-22 03:31:04 UTC
Verified FIXED in Version: 6.1.0.0.alpha0+ (x64)
Build ID: bf8e8cf11bc0d60ab80f5b3420dc424aec2fa626
Small, medium, and large bullets are scaled correctly now. No issues roundtripping the files multiple times. 

Paul Trojahn,
Thank you for resolving this interoperability issue.
Comment 8 Commit Notification 2017-12-30 16:37:20 UTC
Paul Trojahn committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=87e353874a1c52f8e42946a59d2e2079eb28f7fe

tdf#90626 PPTX: Fix image bullet position in PPT

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.