Bug 90637 - Macros Recording is Unavailable in Draw, Impress, Math, Base
Summary: Macros Recording is Unavailable in Draw, Impress, Math, Base
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Macro
  Show dependency treegraph
 
Reported: 2015-04-15 14:36 UTC by actionmystique
Modified: 2017-05-08 12:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description actionmystique 2015-04-15 14:36:56 UTC
Tools -> Options -> Advanced -> Enable macro recording (limited)

Macros -> : no "Record Macro" option
Comment 1 Julien Nabet 2015-04-16 07:48:27 UTC
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/User_Profile#GNU.2FLinux) and give it a new try?
Comment 2 actionmystique 2015-04-16 09:52:48 UTC
the directory name is already correct, except that the LO user is root:
/root/.config/libreoffice/4/user
Comment 3 Julien Nabet 2015-04-16 19:23:33 UTC
Just for the test, could you give a try with a non root user?
Comment 4 actionmystique 2015-04-16 20:18:06 UTC
Yes, same issue if LO Draw 4.4.2.2 is run:
  - as non root user on Ubuntu 14.10
  - or on Windows 7
Comment 5 Julien Nabet 2015-04-17 05:27:33 UTC
Thank you for your feedback, I put it back to UNCONFIRMED since I don't have more questions.
Comment 6 Buovjaga 2015-04-18 12:29:11 UTC
(In reply to actionmystique from comment #2)
> the directory name is already correct, except that the LO user is root:
> /root/.config/libreoffice/4/user

Julien meant to rename it to check, if current profile is corrupted.

I can't reproduce.

Win 7 Pro 64-bit, Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.4.2.2
Build ID: 40m0(Build:2)
Locale: en_US
Comment 7 Matthew Francis 2015-04-27 15:40:25 UTC
I confirm on Ubuntu 14.04 / LO 4.4.2.2

Note that this is specific to Draw, not other components

-> NEW
Comment 8 Matthew Francis 2015-04-27 15:43:07 UTC
Back as far as OOo 3.3.0, "Record Macro" is available in the Writer menu but greyed out in Draw

-> Version: Inherited from OOo
Comment 9 QA Administrators 2016-09-20 09:32:00 UTC Comment hidden (obsolete)
Comment 10 Serge 2017-05-07 16:10:52 UTC
LibreOffice 5.2.6.2
Windows 10 1607 64bits

Macro recording menu.

Available in Calc, Writer
Not displayed in Draw, Impress, Math, Base
Comment 11 Julien Nabet 2017-05-08 08:19:59 UTC
On pc Debian x86-64 with master sources updated some days ago, I could reproduce this.

Yousuf: thought you might be interested in this one since it concerns commands in UI.
I must recognize I don't know if macro recording is disabled for the other apps than Calc and Writer on purpose.
Comment 12 Yousuf Philips (jay) (retired) 2017-05-08 11:38:37 UTC
(In reply to Julien Nabet from comment #11)
> Yousuf: thought you might be interested in this one since it concerns
> commands in UI.
> I must recognize I don't know if macro recording is disabled for the other
> apps than Calc and Writer on purpose.

So help states, "The macro recorder works only in Calc and Writer."

https://help.libreoffice.org/Common/Recording_a_Macro
Comment 13 Julien Nabet 2017-05-08 12:33:42 UTC
Thank you Yousuf for your feedback.
Does this mean that in http://opengrok.libreoffice.org/search?q=MacroRecorder&project=core&defs=&refs=&path=&hist=, all instances of MacroRecord which don't belong to Writer and Calc may be removed?
Comment 14 Yousuf Philips (jay) (retired) 2017-05-08 12:50:15 UTC
As the entries arent visible when they dont function, there isnt a need to remove them.