Download it now!
Bug 90651 - Arrow tool in draw function toolbar in Writer lacks functions that are present in Draw
Summary: Arrow tool in draw function toolbar in Writer lacks functions that are presen...
Status: RESOLVED DUPLICATE of bug 101390
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL: http://nabble.documentfoundation.org/...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-16 11:30 UTC by M Henri Day
Modified: 2016-10-24 19:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
line with arrow on drawing toolbar (261.43 KB, image/bmp)
2015-06-14 00:18 UTC, ELSUPREMO1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M Henri Day 2015-04-16 11:30:49 UTC
​The arrow tool in the draw function toolbar in, e g, Draw or Impress makes drawing an arrow there a breeze, but the same toolbar in Writer (I'm using 4.4.2) lacks this particular​ - and very handy - tool. Arrows can indeed be added in Writer by using the line tool to first draw a line, then right-click one of the end points, select Line in the drop-down menu, and choose the appropriate parameters in the box that then opens, but this procedure is not immediately intuitive for most users. I should therefore like to suggest that the developers consider adding this tool to the draw function toolbar in Writer. Given that it already is found there in Draw and Impress, it should not, I imagine, be too difficult to do so, perhaps already in version 5.0, which we have been told is in the works....

Henri
Comment 1 V Stuart Foote 2015-04-16 14:11:34 UTC
Setting to NEW.

As noted, in Writer a Line object can be modified with its Dialog to style arrow and terminators as needed. But also, that same dialog is the correct way to adjust other properties of all line objects.

At 5.0 the "Line", "Basic Shapes" and "Show Draw Functions" tool buttons are added to the Standard toolbar.

Believe, that the "Lines and Arrows" and "Connectors" group selector buttons should be added to the "Drawing" toolbar for Writer--which is activated from the "Show Draw Functions" button on the Standard toolbar. Those group selectors are now only present in Draw and Impress. But, should require only .uno action assignments.

@Kendy, a potential easy hack?
Comment 2 fossterer 2015-04-16 15:59:36 UTC
Libreoffice Version: 4.2.7.2
Build ID: 420m0(Build:2)

Platform Ubuntu 14.04.2 (x86)

Hi!

@M Henri Day
I can use the "arrow tool" after drawing a "Line" using "Drawing toolbar" in -
Draw
Impress
Calc
Writer

with no difficulty. Did the reported version 4.4.2 lose this ability?

@V Stuart Foote
As you said, "Connectors" appears only in Draw and Impress. Should they do the same in Calc and Writer too?

I observe that clicking on "Points" icon from "Drawing toolbar" in Calc doesn't bring up any additional toolbar which does in all the other 3 applications. Is this anything to be worried about too?
Comment 3 V Stuart Foote 2015-04-16 17:53:01 UTC
(In reply to fossterer from comment #2)
> I can use the "arrow tool" after drawing a "Line" using "Drawing toolbar" in
> -
> Draw
> Impress
> Calc
> Writer
> 
> with no difficulty. Did the reported version 4.4.2 lose this ability?
> 

No, the "Arrow Style" command button remains on the Drawing Object Properties toolbar. Once a line is created, the end style can be directly assigned.

With the Line command button globally available, the Arrow Style command button is available on the Drawing Objects Properties to directly style both ends of any line.  And the Arrow Style command button can also be added to any active toolbar with a customization: Customize Toolbar -> Add from the "Format" category. 

> As you said, "Connectors" appears only in Draw and Impress. Should they do
> the same in Calc and Writer too?

No, Calc is not the UI/UX here, this is an enhancement for Writer.

The grouped "Lines and Arrows" or "Connectors" sets of predefined line styles are not currently exposed to Writer (just to Draw and Impress). So, this is about making those collections of styled lines directly available in the Writer module from a suitable toolbar location. They would then be of some general use there (as opposed to working in Draw with a copy/paste of the objects into Writer).

> I observe that clicking on "Points" icon from "Drawing toolbar" in Calc
> doesn't bring up any additional toolbar which does in all the other 3
> applications. Is this anything to be worried about too?

Worried? No. But off topic.
Comment 4 Jan Holesovsky 2015-04-17 15:13:37 UTC
Stuart: If you can add these commands via Tools -> Customize... to the Writer toolbar, and it works, then indeed, it would be an Easy hack to make it there by default :-)  Can you please check?  Thanks a lot!
Comment 5 V Stuart Foote 2015-04-17 16:09:49 UTC
(In reply to Jan Holesovsky from comment #4)
> Stuart: If you can add these commands via Tools -> Customize... to the
> Writer toolbar, and it works, then indeed, it would be an Easy hack to make
> it there by default :-)  Can you please check?  Thanks a lot!

Unfortunately, I don't think they are linked/implemented for Writer.

The grouping of command buttons making up "Lines and Arrows" and "Connectors" do not appear on the list of Customize -> Add: Add Commands for the Drawing toolbar in Writer.

And in Draw and Impress, I've not been able to locate the grouped objects in the customize dialogs, just the individual command buttons so not sure how they are packaged into a group.

Any ideas?
Comment 6 V Stuart Foote 2015-04-17 16:30:02 UTC
Duh, should have started with the source in OpenGrok

http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/DrawImpressCommands.xcu

Groupings are
.uno:ArrowsToolbox
.uno:ConnectorToolbox

Linking to:
SID_DRAWTBX_ARROWS
http://opengrok.libreoffice.org/xref/core/sd/sdi/sdraw.sdi#199
http://opengrok.libreoffice.org/search?q=SID_DRAWTBX_ARROWS&project=core&defs=&refs=&path=&hist=

SID_DRAWTBX_CONNECTORS
http://opengrok.libreoffice.org/xref/core/sd/sdi/sdraw.sdi#1295
http://opengrok.libreoffice.org/search?q=SID_DRAWTBX_CONNECTORS&project=core&defs=&refs=&path=&hist=

But, these both are from DrawImpressCommands.xcu, whereas the "Arrow Styles" which does show in Writer links to the .uno:LineEndStyle found in Genericcommands.xcu

Not sure how much of an issue it becomes then to link DrawImpress commands into Writer.
Comment 7 ELSUPREMO1 2015-06-14 00:18:27 UTC
Created attachment 116508 [details]
line with arrow on drawing toolbar

Hi, i'm using Libreoffice Version: 4.4.3.2.and confirmed its not on the drawing toolbar as well. As previously mentioned, this is a common user feature and should be standard on every drawing toolbar (see my pic).

Also, I would recommend standardizing the default color for lines to thecolor black not blue. All other shapes are fine.
Comment 8 Maxim Monastirsky 2016-10-24 19:32:52 UTC

*** This bug has been marked as a duplicate of bug 101390 ***