Bug Hunting Session
Bug 90695 - In function Wizard Array box cannot be unchecked
Summary: In function Wizard Array box cannot be unchecked
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Julien Nabet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-18 16:31 UTC by Paweł
Modified: 2015-10-28 15:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ScreenShot of function wizzard (42.89 KB, image/jpeg)
2015-04-18 16:31 UTC, Paweł
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł 2015-04-18 16:31:35 UTC
Created attachment 114882 [details]
ScreenShot of function wizzard

After chceck "Array" option and press "OK" it is immpossible to uncheck this box.
Mayby it is not a bug...
Comment 1 Julien Nabet 2015-04-18 18:21:55 UTC
On pc Debian x86-64 with master sources updated today or with LO Debian package 4.3.3, I don't reproduce this.

On which env and which LO version do you use?
Comment 2 Paweł 2015-04-19 15:11:43 UTC
LO 4.0 - 4.4 on Windows XP, Windows 7
Comment 3 Julien Nabet 2015-04-19 15:22:58 UTC
Thank you for your feedback.

For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) and give a new try?

When you tell "4.4", do you mean 4.4.2 or a previous version? (4.4.0 or 4.4.1)
Comment 4 Paweł 2015-04-19 16:52:51 UTC
This bug has about 10 years and is inherited from OpenOffice.
Attached screenshot file is from LO 4.4.2.2 on windows XP.
Comment 5 Julien Nabet 2015-04-19 17:02:34 UTC
I just noticed I hadn't clicked on OK.
I can reproduce this now.

But I don't know if it's a bug or if it's on purpose.

Since I don't have more questions, I put it back to UNCONFIRMED.
Comment 6 Matthew Francis 2015-04-28 05:28:38 UTC
Let's call this a bug (if not a bug, then an enhancement - this UI could certainly be improved by allowing the array option to be removed)

It has been this way since OOo 3.3.0

-> NEW
-> Version: Inherited from OOo
Comment 7 Commit Notification 2015-10-26 05:15:10 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bebc20c62be2df2cf2741fb82945ce6b631d2fe5

tdf#90695: In function Wizard Array box cannot be unchecked

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Julien Nabet 2015-10-26 06:22:14 UTC
Backport for 5.0 branch in review:
https://gerrit.libreoffice.org/#/c/19598/
Comment 9 Commit Notification 2015-10-26 13:27:28 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=068178adf5de6ca667c0bcd2764519f6555d9d40

Revert "tdf#90695: In function Wizard Array box cannot be unchecked"

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Eike Rathke 2015-10-26 13:30:51 UTC
This is not a bug. When editing an existing formula the checked but disabled Array button is meant as an indicator that the formula IS an array/matrix formula. Unchecking would result in the formula not being applied as array formula anymore, which it was before editing.
Comment 11 Paweł 2015-10-28 15:35:59 UTC
What with Ctrl+Shift+Enter - (it inserts brackets on both side of formula) it works, but I can't remove brackets after click only Enter.