Download it now!
Bug 90744 - Paragraph style with Area fill set Black incorrectly draws fill into Space Above
Summary: Paragraph style with Area fill set Black incorrectly draws fill into Space Above
Status: RESOLVED DUPLICATE of bug 87509
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL: http://nabble.documentfoundation.org/...
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Area-Fill-Tab Regressions-DrawingLayer-FillStyles
  Show dependency treegraph
 
Reported: 2015-04-20 14:29 UTC by V Stuart Foote
Modified: 2018-11-29 06:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
test case, area above paragrapha fills when Black color is set (27.72 KB, application/vnd.oasis.opendocument.text)
2015-04-20 14:34 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-04-20 14:29:04 UTC
Attaching a test document prepared on Windows 7 sp1, 64-bit en-US with
Version: 4.4.3.1
Build ID: b2f347f2ac68821efc00b6f1793cda90af748118
Locale: en_US

This may be continuation of bug 82661 -- Paragraph background fills all space above paragraph, but seems to be a very specific corner case.

In the test document, have modified Title style as Title1, Area fill is set to Gray6 and Font effects have set font to Yellow. Have an Area above of 2.0cm and and Area below of 1.0cm

If the Area fill is modified to Black, the Area above paragraph will be filled black. Revert to Gray6 and area above is not filled--just the line(s) with text. Also seems to be positional, in that if it occurs at a natural page break (or start of document), the area above is not filled. Following a manual page break, it does.

Area fill color other than Black does not manifest the issue.
Comment 1 V Stuart Foote 2015-04-20 14:34:07 UTC
Created attachment 114960 [details]
test case, area above paragrapha fills when Black color is set

test document for issue, modify Title1 paragraph attributes--change Area fill color from Gray6 to Black.  Area above paragraph will incorrectly be drawn filled.
Comment 2 V Stuart Foote 2015-04-20 14:42:53 UTC
Incorrect area fill when color set to black also noted with recent master on Fedora21 w/LXDE

Version: 4.5.0.0.alpha0+
Build ID: c3087d969671e62182eb049850479e77190ccff4
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-03-22_02:33:12
Locale: en_US
Comment 3 Pieter van Oostrum 2015-04-20 19:30:08 UTC
I don't see this happen with version 4.4.3.1 (rc1)

The black background looks OK in that version, bith when I apply the black background color with Format->Paragraph and by changing the style.
Comment 4 Pieter van Oostrum 2015-04-20 19:31:29 UTC
I should have added: On Mac OS X 10.10.3, as the bug was reported on 4.4.3.1
Comment 5 Matthew Francis 2015-04-22 03:23:40 UTC
This seems to have been fixed for everything but black by the below commit.

(Note: I can reproduce when setting the paragraph background of "Title 2" in the attached document to black, but not "Title 1")


    commit 1e33cd8355eb1d856a1439b4a095e379b3acf0bd
    Author:     Miklos Vajna <vmiklos@collabora.co.uk>
    AuthorDate: Tue Feb 17 12:16:54 2015 +0100
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Tue Feb 17 12:34:35 2015 +0100
    
        tdf#82661 SwFrm::PaintBackground: handle fill attrs when comparing background
    
        Regression from 7d9bb549d498d6beed2c4050c402d09643febdfa (Related:
        i#124638 Second step of DrawingLayer FillAttributes..., 2014-06-02),
        should be good enough till SdrAllFillAttributesHelper gets its own
        operator ==().
    
        Change-Id: I03f847bc1589e3771790427d9894cc330a7b8dc6
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:12:01 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2016-09-26 09:26:13 UTC
Adding Cc: to Miklos Vajna
Comment 8 Justin L 2018-11-29 06:00:27 UTC

*** This bug has been marked as a duplicate of bug 87509 ***