Bug 90754 - Refresh icon in LO custom dialog missing transparency
Summary: Refresh icon in LO custom dialog missing transparency
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 101307 (view as bug list)
Depends on:
Blocks: LO-File-Dialog UI-Theming
  Show dependency treegraph
 
Reported: 2015-04-20 20:36 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-05-15 14:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (101.46 KB, image/png)
2015-04-22 22:44 UTC, Yousuf Philips (jay) (retired)
Details
Shot of LO 4.3 (27.47 KB, image/png)
2015-04-23 11:21 UTC, Dave Richards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-04-20 20:36:24 UTC
Steps:
1) Enable LO's custom file dialogs (Tools > Options > General > Use LO dialogs)
2) File > Open
3) Click 'Servers...' button
4) Select 'CMIS' in the Type drop down
5) Look at the refresh button next to the repository drop down and there is a black background where the transparency is supposed to be

In LO 4.0 to 4.4, the transparency was filled with a white background, so it isnt that noticeable on a lighter theme, but that is still a problem.

How it looks - http://ibin.co/1z17KYLvfCn5

Version: 5.0.0.0.alpha0+
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-18_00:37:15
Comment 1 Adolfo Jayme Barrientos 2015-04-22 21:35:21 UTC
Removing the “regression” keyword. This is apparently an issue with the Breeze theme only, as it can be seen in the screenshot.
Comment 2 Yousuf Philips (jay) (retired) 2015-04-22 22:44:03 UTC
Created attachment 115017 [details]
screenshot
Comment 3 Yousuf Philips (jay) (retired) 2015-04-22 22:48:23 UTC
This does not only affect breeze, it affects all icon themes that i've tested - galaxy, tango, oxygen, sifr. With oxygen, its completely a black square.

The screenshot was given to me by Dave and i confirmed it so setting to NEW.
Comment 4 Dave Richards 2015-04-23 11:21:28 UTC
Created attachment 115032 [details]
Shot of LO 4.3

This icon has been not ideal for as long as I can remember.  In 4.3, it's got a white background and pixelated.
Comment 5 Adolfo Jayme Barrientos 2015-05-13 04:15:39 UTC
Still not a regression then.
Comment 6 Yousuf Philips (jay) (retired) 2016-08-05 10:01:15 UTC
*** Bug 101307 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2017-10-23 14:12:50 UTC Comment hidden (obsolete)
Comment 8 Yousuf Philips (jay) (retired) 2017-11-30 08:38:05 UTC
*** Bug 101307 has been marked as a duplicate of this bug. ***
Comment 9 CassieMoondust 2018-03-11 21:31:55 UTC
In 6.0.2 the icon is looking good to me.
System: KDE neon 5.12.3

Can we close this bug?
Comment 10 QA Administrators 2019-06-10 02:57:07 UTC Comment hidden (obsolete)
Comment 11 Rizal Muttaqin 2020-04-28 03:00:10 UTC
The bug has been fixed in these version

버전: 7.0.0.0.alpha0+
빌드 번호: 9e8bb8fa8a77665552db9c01cac1034d5040da7b
CPU 스레드: 4; OS: Linux 4.20; UI 표현: 기본; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-04-24_20:27:57
지역 설정: id-ID (id_ID.UTF-8); UI-Language: ko-KR
Calc: threaded

Versi: 6.4.3.2
ID Build: 1:6.4.3-0ubuntu0.18.04.1
Thread CPU: 4; OS: Linux 4.20; Render UI: baku; VCL: kf5; 
Locale: id-ID (id_ID.UTF-8); Bahasa-UI: id-ID
Calc: threaded
Comment 12 BogdanB 2020-05-15 14:42:30 UTC
it's ok on
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 0e3196c49b84651df20b770d5cd7f0bbb19dfc40
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded