Download it now!
Bug 90790 - ICONS: Parent icon theme links.txt duplicate records not used in child themes
Summary: ICONS: Parent icon theme links.txt duplicate records not used in child themes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: highest major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.0.2
Keywords: regression
: 92105 92168 (view as bug list)
Depends on:
Blocks: mab5.0
  Show dependency treegraph
 
Reported: 2015-04-22 20:49 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-25 19:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (45.44 KB, image/png)
2015-04-22 20:49 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-04-22 20:49:58 UTC
Created attachment 115015 [details]
screenshot

The galaxy links.txt file has the below entry

cmd/lc_formatselection.png sfx2/res/symphony/sidebar-property-large.png

which is to show the same icon that appears as the sidebar properties' sidebar button in the 'Format Selection' button but this does not work in child themes like tango and breeze and instead it shows the same galaxy icon in that position.

This is a regression that started in the 4.5/5.0 branch.

Version: 5.0.0.0.alpha1+
Build ID: badec7478035008f514e0976a94438fe2e32dc40
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-22_00:50:58
Comment 1 tommy27 2015-05-24 11:32:04 UTC
works for me under Win8 using LO  5.1.0.0.alpha1+
Build ID: 83eb114394879cbfd073322a51c47d02553c1fcf
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-22_06:33:51
Locale: en-US (it_IT)

the Breeze and Tango themes display a proper Legend On/Off icon rather than the icon from Galaxy theme like in your screenshot.

are you still seeing this issue?
Comment 2 Yousuf Philips (jay) (retired) 2015-05-26 22:13:20 UTC
The issue is still present in master updated today. The 'Format Selection' button should be the same 'Properties' button found in the sidebar, but instead it shows the 'Properties' button found in Galaxy's icon theme.

Another example of this can be found with :-
1) Open Writer
2) Insert an image
3) The 'Forward One' and 'Back One' button are from Galaxy
Comment 3 Yousuf Philips (jay) (retired) 2015-06-21 16:26:33 UTC
*** Bug 92168 has been marked as a duplicate of this bug. ***
Comment 4 Yousuf Philips (jay) (retired) 2015-06-21 16:26:53 UTC
*** Bug 92105 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2015-06-23 10:38:37 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=43a082f0bba799a9fc33071079f7a42932935e05

tdf#90790: Don't take galaxy as a reference icon set, it may be incomplete.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Jan Holesovsky 2015-06-23 10:44:11 UTC
Fixed now, was a packaging issue.
Comment 7 Commit Notification 2015-06-23 14:31:39 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=41d1bd782ccb888fdfe2566ad7513bdaccba689d&h=libreoffice-5-0

tdf#90790: Don't take galaxy as a reference icon set, it may be incomplete.

It will be available in 5.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.