Bug Hunting Session
Bug 90804 - Style preview doesnt show correctly in the Font tab
Summary: Style preview doesnt show correctly in the Font tab
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.1 rc
Hardware: All All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta2 tar...
Keywords: regression
: 88785 90785 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-23 06:16 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-25 19:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-04-23 06:16:34 UTC
Steps:
1) Open Writer
2) Modify the 'Heading 1' Style
3) Click on Font tab
4) Notice preview is written with tiny letters

Regression that affects master and 4.4 daily.

Version: 5.0.0.0.alpha1+
Build ID: badec7478035008f514e0976a94438fe2e32dc40
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-22_00:50:58
Comment 1 Tomaz Vajngerl 2015-04-23 07:08:24 UTC
That happens when the font size is defined relative (in percents). Looks like we interpret it as absolute (just my guess) in the preview.
Comment 2 Yousuf Philips (jay) (retired) 2015-04-23 13:12:50 UTC
I thought so as well, but its weird that its only limited to the 'Font' tab as the 'Font Effects' tab shows it fine.
Comment 3 Commit Notification 2015-06-08 13:44:56 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7f4230675c6c78ebea8b6db3f3612e3ef6fb23df

tdf#90804 remove SfxFieldUnit enum

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2015-06-08 14:13:16 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fdc99b23b56414fa126814f9c64554f19f883326&h=libreoffice-5-0

tdf#90804 remove SfxFieldUnit enum

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Andras Timar 2015-06-08 15:09:17 UTC
https://gerrit.libreoffice.org/#/c/16162/ for libreoffice-4-4
Comment 6 Commit Notification 2015-06-08 21:00:31 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a78f63f513cee4e1caeb730dae270e76b1009e14&h=libreoffice-4-4

tdf#90804 Revert "remove unused values from SfxFieldUnit enum"

It will be available in 4.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Andras Timar 2015-06-14 20:24:15 UTC
*** Bug 88785 has been marked as a duplicate of this bug. ***
Comment 8 Matthew Francis 2015-08-16 00:10:57 UTC
*** Bug 90785 has been marked as a duplicate of this bug. ***