Bug 90830 - The folder res/helpimg is missing in the Tango and Oxygen icon set
Summary: The folder res/helpimg is missing in the Tango and Oxygen icon set
Status: RESOLVED DUPLICATE of bug 75637
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: All All
: low normal
Assignee: Adolfo Jayme
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks: UI-Theming Help-Viewer
  Show dependency treegraph
 
Reported: 2015-04-24 11:46 UTC by Regina Henschel
Modified: 2017-06-29 21:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2015-04-24 11:46:53 UTC
The folder /res/helpimg contains some icons, which are used in the help itself. Try the topic "The LibreOffice Help Window". If you have chosen "Tango" or "Oxygen" some icons are missing, if you have chosen "Galaxy" the icons are shown.
Comment 1 Julien Nabet 2015-05-17 21:21:27 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.

Code pointer: http://opengrok.libreoffice.org/xref/core/xmlhelp/util/main_transform.xsl#121
Galaxy is ok because icon-themes/galaxy/res/helpimg contain at least these 3 files:
note.png
tip.png
warning.png

Here's the console log:
warn:unotools.misc:12502:1:unotools/source/misc/mediadescriptor.cxx:738: caught Exception "Got no data stream!" while opening <vnd.sun.star.zip://file:%2F%2F%2Fhome%2Fjulien%2Fcompile-libreoffice%2Flibreoffice%2Finstdir%2Fshare%2Fconfig%2Fimages_tango.zip/res/helpimg/warning.png>
warn:sw.html:12502:1:sw/source/filter/html/htmlgrin.cxx:822: html image with no width or height
warn:sw:12502:1:sw/inc/swrect.hxx:296: SVRect() without Width or Height
warn:sw:12502:1:sw/inc/swrect.hxx:296: SVRect() without Width or Height
warn:sw:12502:1:sw/inc/swrect.hxx:296: SVRect() without Width or Height
warn:sw:12502:1:sw/inc/swrect.hxx:296: SVRect() without Width or Height
warn:legacy.osl:12502:1:sfx2/source/appl/workwin.cxx:2082: The ChildWindow is not registered!
warn:unotools.misc:12502:23:unotools/source/misc/mediadescriptor.cxx:738: caught Exception "Got no data stream!" while opening <vnd.sun.star.zip://file:%2F%2F%2Fhome%2Fjulien%2Fcompile-libreoffice%2Flibreoffice%2Finstdir%2Fshare%2Fconfig%2Fimages_tango.zip/res/helpimg/warning.png>
warn:legacy.tools:12502:1:sot/source/base/exchange.cxx:360: SotExchange::GetFormatDataFlavor(): DataFlavor not initialized
warn:sfx.appl:12502:1:sfx2/source/appl/fileobj.cxx:326: Graphic error [1] - [] URL[vnd.sun.star.zip://file:%2F%2F%2Fhome%2Fjulien%2Fcompile-libreoffice%2Flibreoffice%2Finstdir%2Fshare%2Fconfig%2Fimages_tango.zip/res/helpimg/warning.png]

Adolfo: one for you?
Comment 2 Adolfo Jayme 2015-05-20 00:28:39 UTC
I’ll upload preliminary icons for Tango, which will be fine-tuned later. I’m not sure if it’s worth to fix Oxygen, though.
Comment 3 Commit Notification 2015-05-20 00:31:05 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2a886adb500fe481e1ea61573551b19e99c55b8b

tdf#90830 Add Tango help icons

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 ace_dent 2015-07-01 21:52:44 UTC
Hi.

I had removed those, after discussion with Kendy.
Previously the build system would have fallen back to images in the Galaxy theme when packing the images into the theme's zip archive (packimage).
Something changed here?
Comment 5 ace_dent 2015-07-02 16:26:09 UTC
I think I understand the Issue and fix now...
You may want to check: https://bugs.documentfoundation.org//show_bug.cgi?id=75637
Comment 6 Xisco Faulí 2017-03-01 11:04:26 UTC
Hello Adolfo,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 7 Gabor Kelemen 2017-06-29 21:02:25 UTC
I can't see this happening anymore.
Let's assume it was the same as bug 75637 as per comment 5

*** This bug has been marked as a duplicate of bug 75637 ***