Download it now!
Bug 90845 - CONTEXT MENU: Context menu submenus dont appear with icons
Summary: CONTEXT MENU: Context menu submenus dont appear with icons
Status: RESOLVED DUPLICATE of bug 93837
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2015-04-24 20:46 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-01-20 22:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
printscreen (65.29 KB, image/png)
2015-04-25 11:11 UTC, raal
Details
printscreen (44.62 KB, image/png)
2015-04-25 14:11 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-04-24 20:46:21 UTC
I had previously set the icons for the submenus Anchor, Wrap, Alignment, and Arrangement but they dont show up in the context menu, though they do appear in the Format menu. So i'm assuming that no context menu submenus have icons whether they are set to have one or not.

Steps:
1) Open Writer
2) Open Format menu, notice that the Anchor submenu entry has an icon
3) Insert an image or shape
4) Right-click on the image or shape
5) Notice that the Anchor submenu entry doenst have an icon

Version: 5.0.0.0.alpha1+
Build ID: badec7478035008f514e0976a94438fe2e32dc40
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-22_00:50:58

I had set these icons in this commit.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d21eae2447c227ad945d2b9df8cab895f792dd04
Comment 1 raal 2015-04-25 11:11:44 UTC
Created attachment 115085 [details]
printscreen

I've not icons in menu Format/Anchor

Version: 5.0.0.0.alpha1+
Build ID: e9fbe1f7cd28de2a9da8089d89e903406165eb56
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-25_00:20:28
Comment 2 Yousuf Philips (jay) (retired) 2015-04-25 13:53:11 UTC
Try changing Tools > Options > View > Icons in Menus.
Comment 3 raal 2015-04-25 14:11:45 UTC
Created attachment 115087 [details]
printscreen

Tools > Options > View > Icons in Menus > Show

Version: 5.0.0.0.alpha1+
Build ID: e9fbe1f7cd28de2a9da8089d89e903406165eb56
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-25_00:20:28
Comment 4 Yousuf Philips (jay) (retired) 2015-04-25 14:38:08 UTC
Yes your screenshot shows it icons for Anchor, Wrap, Alignment, and Arrangement, which dont appear in the context menu.
Comment 5 Maxim Monastirsky 2016-01-20 22:47:03 UTC
Fixed as a side effect of Bug 93837 (as now we share the same code for menubar and context menus).

*** This bug has been marked as a duplicate of bug 93837 ***