Bug Hunting Session
Bug 90885 - Start center thumbnail delete button appearing over thumbnail
Summary: Start center thumbnail delete button appearing over thumbnail
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha1
Hardware: Other All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2015-04-26 19:14 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-16 05:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (98.51 KB, image/png)
2015-04-26 19:14 UTC, Yousuf Philips (jay) (retired)
Details
thumbnail view of Calc spreadsheet, seems reasonable (105.74 KB, image/png)
2015-04-26 20:30 UTC, V Stuart Foote
Details
sample file (8.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-04-26 21:59 UTC, Yousuf Philips (jay) (retired)
Details
screenshot from LibO 5.0.3 (74.98 KB, image/png)
2015-11-01 18:04 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-04-26 19:14:48 UTC
Created attachment 115124 [details]
screenshot

Did some editing of a spreadsheet and then closed it to go back to the start center and noticed that the thumbnail delete button appeared over its thumbnail, as show in the attached screenshot.

Version: 5.0.0.0.alpha1+
Build ID: badec7478035008f514e0976a94438fe2e32dc40
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-22_00:50:58
Comment 1 V Stuart Foote 2015-04-26 20:30:34 UTC
Created attachment 115125 [details]
thumbnail view of Calc spreadsheet, seems reasonable

Can't reproduce...

On Windows 7 sp1, 64-bit en-US
Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: en_US

With a recently reset profile, Calc spreadsheet has a reasonably sized thumbnail as attached. Nothing weird about its size or obscuring the delete button.
Comment 2 Yousuf Philips (jay) (retired) 2015-04-26 21:59:00 UTC
Created attachment 115126 [details]
sample file

Unfortunately the original screenshot file has been modified so it no longer shows the thumbnail as previously shown, so here is a sample file which does it.
Comment 3 V Stuart Foote 2015-04-26 22:31:44 UTC
Confirming with the attached test file...
Comment 4 Yousuf Philips (jay) (retired) 2015-06-10 18:43:59 UTC
It isnt as bad now as the delete button has a circular background, but it still appears over the thumbnail.
Comment 5 tommy27 2015-11-01 12:06:46 UTC
This is resolved in current 5.0.x releases the delete button is outside the thumbnail
Comment 6 Yousuf Philips (jay) (retired) 2015-11-01 13:55:21 UTC
Not resolved with attachment 115126 [details] and many other writer docs i have in my start center.

Version: 5.1.0.0.alpha1+
Build ID: 048bc383f1d2c15f690364d0001045cdf7090f6f
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-28_00:39:39
Locale: en-US (en_US.UTF-8)
Comment 7 tommy27 2015-11-01 18:03:36 UTC
you are right... in some files the delete button is still over the thumbnails but in other it's outside of it.

liek you said in comment 4 thanks to the new circular design of the button it doesn't look annoying as before  so I wonder if we really need to take care of this of if we may close it as WONTFIX due to the very minor residual annoyance (if any)
Comment 8 tommy27 2015-11-01 18:04:11 UTC
Created attachment 120168 [details]
screenshot from LibO 5.0.3
Comment 9 Yousuf Philips (jay) (retired) 2015-11-01 23:48:02 UTC
Not such a major issue so lets leave it as WORKSFORME.
Comment 10 Robinson Tryon (qubit) 2015-12-16 05:30:50 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval, topicUI)
[NinjaEdit]