Bug 90897 - distorted colors with 3D slide transition
Summary: distorted colors with 3D slide transition
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OpenGL
  Show dependency treegraph
 
Reported: 2015-04-27 19:29 UTC by Roman Kuznetsov
Modified: 2015-11-29 17:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2015-04-27 19:29:06 UTC
Version: 5.0.0.0.alpha1+
ID build: e24a02dc29d6e750ee4270dac429c8416c5b738c
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-04-22_15:26:19
Locale: ru_RU

when viewing a presentation with 3D slide transitions can be seen that the color slides are distorted when the slide transition.

link to video https://yadi.sk/i/IOr9Wy0DgHUbA
link to presentation https://yadi.sk/i/dYbQEKg6gHUum
Comment 1 Buovjaga 2015-04-28 10:50:21 UTC
Yes, the colors are wrong until transition finished.
Windows-only problem.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f0edb677f09ad338e22ac3b5d91497b4479e0b3c
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-27_01:54:20
Locale: fi_FI

Ubuntu 15.04 64-bit 
Version: 5.0.0.0.alpha1+
Build ID: daa28969374f628a8cb265fcb28a73daabcb7236
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-04-25_00:48:25
Locale: en_US
Comment 2 Roman Kuznetsov 2015-10-03 12:36:43 UTC
Версия: 5.0.2.1 (x64)
ID сборки: 9a18d52abbdfbdc2ac9acebec2b92e7859eb73b7
Локаль: ru-RU (ru_RU)

bug is reproduced

Версия: 5.1.0.0.alpha1+
ID сборки: 25de5cfa43b2b1cb7d7214470acc7719839e13fe-GL
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-01_08:49:54
Локаль: ru-RU (ru_RU)

bug is not reproduced. Colors in slide with 3D slide transition not distorted.
Comment 3 Michael Meeks 2015-10-15 13:58:54 UTC
Can't reproduce this myself with a -5-0 build on Windows / AMD or on Linux; just doing a new one there. Might be worth checking with a newer -5-0 snapshot: it could well be a mis-interaction of hardware-acceleration (DirectX) with GL rendering - that should be disabled in more recently 5.0 builds.

Please re-open if you can reproduce with something 5.0.3 RC1 based; thanks !
Comment 4 Buovjaga 2015-10-16 18:00:54 UTC
With hardware acceleration disabled, the colors are ok.
But I reproduced it still with HW acceleration enabled, so can we really mark this as fixed?

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 186f32f63434e16ff5776251657f902d5808ed3d
TinderBox: Win-x86@39, Branch:master, Time: 2015-10-16_09:42:47
Locale: en-US (fi_FI)