Download it now!
Bug 90922 - Android Viewer needs manual locale selection feature
Summary: Android Viewer needs manual locale selection feature
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 98171 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-29 09:44 UTC by Michael Bauer
Modified: 2020-03-10 09:47 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the language setting in Android Viewer (80.84 KB, image/png)
2020-03-09 15:46 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Bauer 2015-04-29 09:44:56 UTC
The number and selection of locales available on Android vary from country to country, manufacturer to manufacturer and even handset to handset. Most locales are (though theoretically part of Android) not on offer. Especially small-to-medium locales are often affected by this.

Because LO has localized products in many small to medium locales (like Irish (ga) or Scottish Gaelic (gd)) force-locale to set the UI language of the Viewer should be complemented by a feature where the end-user can manually set a different locale for the Viewer UI language.

Increasingly, especially open software offers such features for exactly these reasons, e.g. Firefox Mobile, VLC, WordPress.
Comment 1 raal 2015-04-29 11:38:55 UTC
enhancement, setting to new
Comment 2 Christian Lohmaier 2015-05-26 12:31:03 UTC
(currently the Viewer doesn't ship with any translations)
Comment 3 Michael Bauer 2015-05-26 13:06:51 UTC
I didn't think it did but after the problem with getting locale selection into the Remote or indeed VLC or Mozilla Mobile, I wanted to file a bug as soon as possible to put this issue on the radar.
Comment 4 Xisco Faulí 2017-07-13 12:38:23 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 5 Xisco Faulí 2018-01-23 08:22:52 UTC
*** Bug 98171 has been marked as a duplicate of this bug. ***
Comment 6 Michael Weghorn 2020-03-09 15:28:10 UTC
Selecting locale is possible in the current version of LibreOffice Android Viewer, therefore closing as WORKSFORME.
Comment 7 Michael Bauer 2020-03-09 15:36:49 UTC
There is no locale/UI language selection function in LO Viewer on Android that I can see.
Comment 8 Michael Weghorn 2020-03-09 15:46:12 UTC
Created attachment 158519 [details]
Screenshot of the language setting in Android Viewer
Comment 9 Michael Weghorn 2020-03-09 15:48:11 UTC
It's available when you open the top-right menu, then select "Settings", s. attached screenshot, attachment 158519 [details].

What version are you using?
If you're currently using an older one, can you please retest with a daily build from https://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-Hosting/ ?
Comment 10 Michael Bauer 2020-03-09 15:53:02 UTC
6.1.0.0alpha0+

The only thing I see under General is "Experimental Features". I think it's premature to close the bug before the issue is resolved in release. I'll see if I can make time to install a daily build over the next few days.
Comment 11 Michael Weghorn 2020-03-09 15:59:43 UTC
(In reply to Michael Bauer from comment #10)
> 6.1.0.0alpha0+

Quite likely this rather old version doesn't have the option yet, and unfortunately, there haven't been actual "releases" for quite a while, so the daily build is probably what you'd want for now.

> The only thing I see under General is "Experimental Features". I think it's
> premature to close the bug before the issue is resolved in release. I'll see
> if I can make time to install a daily build over the next few days.

Well, in my understanding, closing bug reports once they have been fixed on master is the standard workflow here...
(and I don't think that Android Viewer had any releases apart from those built from git master, unlike the desktop variants)
Comment 12 Michael Bauer 2020-03-09 16:15:50 UTC
If there's no release likely in the near future, that's even more of a reason to keep the bug open for now, even if usual practice might be to close when fixed on master. Otherwise we'll just end up with duplicate bugs which cost everyone a lot more time and effort that keeping this one open for now.
Comment 13 Michael Weghorn 2020-03-09 16:54:34 UTC
(In reply to Michael Bauer from comment #12)
> If there's no release likely in the near future, that's even more of a
> reason to keep the bug open for now, even if usual practice might be to
> close when fixed on master. Otherwise we'll just end up with duplicate bugs
> which cost everyone a lot more time and effort that keeping this one open
> for now.

Fine for me...
Comment 14 Adolfo Jayme 2020-03-09 22:12:21 UTC
> If there's no release likely in the near future

Who said that? Why don’t y’all ask Cloph instead of (involuntarily) spreading FUD? :)

> closing bug reports once they have been fixed on master is the standard
> workflow here

Indeed. And Bugzilla’s search also allows to look for closed issues. Possible duplicates aren’t a problem.
Comment 15 Adolfo Jayme 2020-03-09 22:22:40 UTC
BTW, this was fixed by core commit 5bf2ec9ed8728a2042e110122ea2b0e4ff55104a. There are only two translations (German and Turkish), because this is not on Weblate. Cloph?
Comment 16 Michael Bauer 2020-03-10 09:47:53 UTC
>Who said that? Why don’t y’all ask Cloph instead of (involuntarily) spreading FUD? :)

Cause we're not all plugged in to the matrix? Some of us exist outside the LOniverse...