Bug 90925 - footnote mark in heading is displayed in table of contents (TOC)
Summary: footnote mark in heading is displayed in table of contents (TOC)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta4
Keywords: bibisected, bisected, regression
: 92563 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-29 11:45 UTC by Andras Timar
Modified: 2016-10-25 19:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample document (ODT) (12.00 KB, application/vnd.oasis.opendocument.text)
2015-04-29 11:45 UTC, Andras Timar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-04-29 11:45:20 UTC
Created attachment 115179 [details]
sample document (ODT)

When a heading contains a footnote mark, this footnote mark get into the table of contents. This behaviour is not desirable, because footnote mark makes no sense in TOC. 

So instead of "Heading heading", there is "Heading1 heading" in the TOC.

It is a regression.
e5345f62bf525b6258736f1ce11a61b5e638e0ff is the first bad commit
commit e5345f62bf525b6258736f1ce11a61b5e638e0ff
Author: Tobias Lippert <drtl@fastmail.fm>
Date:   Sun Jun 1 14:15:35 2014 +0200

    Unittest the whitespace stripping logic for tox text generation
    
    The separate class allows to unittest this functionality in isoloation.
    
    Change-Id: I1e5eddfb455ca85a662ea38c03302883decc5d58
    Reviewed-on: https://gerrit.libreoffice.org/9608
    Tested-by: Caolán McNamara <caolanm@redhat.com>
    Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Comment 1 Commit Notification 2015-06-11 20:04:15 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f20c03acac4774bc99cc8f33271f12aa2a290788

tdf#90713 tdf#90925 remove footnote mark from TOC/List of Figures entry

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2015-06-11 20:32:03 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5498f7f5d11250a8425920c71fcb4e2069dc283a&h=libreoffice-5-0

tdf#90713 tdf#90925 remove footnote mark from TOC/List of Figures entry

It will be available in 5.0.0.0.beta4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Gordo 2015-07-06 00:43:48 UTC
*** Bug 92563 has been marked as a duplicate of this bug. ***
Comment 4 Robinson Tryon (qubit) 2015-12-17 08:59:29 UTC Comment hidden (obsolete)