Bug Hunting Session
Bug 90941 - Calc - "Conversion from text to numbers: Treat text as zeroes" does not work with matrices
Summary: Calc - "Conversion from text to numbers: Treat text as zeroes" does not work ...
Status: CLOSED DUPLICATE of bug 91453
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.7.1 rc
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2015-04-29 16:22 UTC by tvo_nospam
Modified: 2015-12-17 08:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Demo sheet showing simple SUM() calculations (which work with string cells) and matrices (which don't work with strings in the cells) (38.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-04-29 16:22 UTC, tvo_nospam
Details
Screenshot of the demo sheet under Calc 4.3.7.2 (x86_64, Opensuse 13.1) (71.10 KB, image/png)
2015-05-01 15:36 UTC, tvo_nospam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tvo_nospam 2015-04-29 16:22:29 UTC
Created attachment 115192 [details]
Demo sheet showing simple SUM() calculations (which work with string cells) and matrices (which don't work with strings in the cells)

Since 4.3.7 calc offers to select how text values are treated when formulas expect numeric values (Tools → Options → LibreOffice Calc → Formula  → Detailed calculation settings → Custom → "Conversion from text to numbers").

The option "Treat text as zeroes" does not work when text cells are found inside matrix calculations (entered by Shift+Ctrl+Enter, displayed as {=...}): Within matrices, non empty text values still lead to #VALUE! errors (data type mismatch). See the attached demo sheet (produced with calc 4.3.7.2).

Especially, old sheets will not work any more if they relied on this (old behaviour was to treat arbitrary text values as zeroes).
Comment 1 Buovjaga 2015-04-29 18:41:09 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f0edb677f09ad338e22ac3b5d91497b4479e0b3c
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-27_01:54:20
Locale: fi_FI
Comment 2 tvo_nospam 2015-05-01 01:28:50 UTC
Tried further, there exists no work around. Old sheets created prior to 4.3.7 that rely on the old conversion rules will not be able to work anymore.
Comment 3 Cor Nouws 2015-05-01 14:31:03 UTC
hi tvo,

Thanks for the clear sample file!
I tried but see no difference between how it behaves in 4.3.6 and 4.3.7 and 5.0.0 alpha 1 - all on Ubuntu 32 bits.
So can I miss something?

Cor
Comment 4 tvo_nospam 2015-05-01 15:36:40 UTC
Created attachment 115240 [details]
Screenshot of  the demo sheet under Calc 4.3.7.2 (x86_64, Opensuse 13.1)
Comment 5 tvo_nospam 2015-05-01 15:50:43 UTC
Hi Cor,

what do you mean by "I see no difference how it behaves in 4.3.6, 4.3.7, 5.0.0a1"? In general, you can recognize the bug (now also visible on the screenshot I attached) on your system?

I first noticed this bug under 4.3.7.2. As I read from Beluga, it's also confirmed for 5.0.0a1+. My previously installed version was 4.3.6.2, where I did _not_ recognize the bug. (Unfortunately, I cannot switch back to 4.3.6.2 on my system fast and easily, as I installed it on OpenSUSE 13.1 (64 Bit) from the OpenSUSE Build Service directory, where 4.3.6.2 is not available any more.)

tvo
Comment 6 Buovjaga 2015-05-01 15:58:17 UTC
(In reply to tvo_nospam from comment #5)
> I first noticed this bug under 4.3.7.2. As I read from Beluga, it's also
> confirmed for 5.0.0a1+. My previously installed version was 4.3.6.2, where I
> did _not_ recognize the bug. (Unfortunately, I cannot switch back to 4.3.6.2
> on my system fast and easily, as I installed it on OpenSUSE 13.1 (64 Bit)
> from the OpenSUSE Build Service directory, where 4.3.6.2 is not available
> any more.)

Here's how you can run different versions in parallel: https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Instructions mention, how you can even run them with their own user profiles.
Comment 7 Eike Rathke 2015-06-17 08:58:58 UTC

*** This bug has been marked as a duplicate of bug 91453 ***
Comment 8 Robinson Tryon (qubit) 2015-12-17 08:59:42 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]