Bug Hunting Session
Bug 90999 - Broken SpreadsheetML import of cells with inline formatting tags
Summary: Broken SpreadsheetML import of cells with inline formatting tags
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Robert Antoni Buj i Gelonch
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta2 tar...
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-01 18:05 UTC by Andras Timar
Modified: 2016-10-25 19:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc (SpreadsheetML) (9.97 KB, application/x-msexcel)
2015-05-01 18:05 UTC, Andras Timar
Details
printscreen (29.50 KB, image/png)
2015-05-02 06:05 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-05-01 18:05:08 UTC
Created attachment 115245 [details]
bugdoc (SpreadsheetML)

The contents of the attached SpreadsheetML file is not imported correctly. 
In cell A1: 
<ss:Data ss:Type="String">ANTANANARIVO<html:Sup>2</html:Sup></ss:Data>
Only "2" (subscript) is imported.
In cell B1:
<ss:Data ss:Type="String"><html:U>ANTA</html:U>NANARIVO</ss:Data>
Only "ANTA" (underlined) is imported. 

Processing is done with filter/source/xslt/import/spreadsheetml/spreadsheetml2ooo.xsl, it has to be fixed by an XSLT expert.
Comment 1 raal 2015-05-02 06:05:29 UTC
Created attachment 115258 [details]
printscreen

I can confirm with Version: 5.0.0.0.alpha1+
Build ID: 59adad74084e9281887e3f78a225794f37b784d7
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-29_12:40:39
Comment 2 Andras Timar 2015-05-19 12:52:41 UTC
Robert, I'm adding you to cc, because you fixed many XSLT bugs recently.
Comment 3 Commit Notification 2015-05-21 07:21:04 UTC
Robert Antoni Buj Gelonch committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0cd2895e70eb96083ea78b1350583fe791b4237a

tdf#90999: Import spreadsheetML cells with inline formatting tags

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2015-05-21 09:52:44 UTC
Robert Antoni Buj Gelonch committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d861027a8234b85504bf614ca653bfa5a378a36c&h=libreoffice-5-0

tdf#90999: Import spreadsheetML cells with inline formatting tags

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-05-21 13:23:03 UTC
Robert Antoni Buj Gelonch committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=26c6602c9036e12e0d228b6f5377f47fde5a530f&h=libreoffice-4-4

tdf#90999: Import spreadsheetML cells with inline formatting tags

It will be available in 4.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.