Download it now!
Bug 91027 - Crash when creating a brand hsqldb embedded base
Summary: Crash when creating a brand hsqldb embedded base
Status: RESOLVED DUPLICATE of bug 91157
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0
Keywords: haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2015-05-02 18:17 UTC by Julien Nabet
Modified: 2015-05-08 16:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (9.17 KB, text/plain)
2015-05-02 18:17 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2015-05-02 18:17:21 UTC
Created attachment 115276 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I had a crash with this step-by-step process:
1) Open Base with no file
2) Select Create a new Database HsqlDB Embedded then Next
3) Click Finish
4) Type "test.odb" (without quotes) for the file name
5) Click Save
=> Crash
Comment 1 Julien Nabet 2015-05-02 18:20:54 UTC
Put it at New since there's a bt.

I retrieved a bt after having putting a break in gdb since we've got only Application::Abort

I forgot to tell in description I use enable-dbgutil.

Michael: thought you might be interested in this one since it seems to be linked with the new vclptr management.
Comment 2 Michael Meeks 2015-05-03 21:04:33 UTC
Thanks ! looking at it =)
Comment 3 Commit Notification 2015-05-05 09:14:38 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=36c8dd27b19ce5088b65096af5f464ec5720efaa

tdf#91027 - cleanup dbaccess related dispose logic.

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Julien Nabet 2015-05-06 21:34:45 UTC
Just for the record, I still got the abort with master sources updated today:
commit 45ed509f71aeef52cb86cc3d88aa2bcf86334bb7
Author: Juergen Funk <juergen.funk_ml@cib.de>
Date:   Wed May 6 14:12:15 2015 +0200

warn:legacy.osl:3087:1:vcl/source/window/window.cxx:271: Window ( N3svt8ORoadmapE (Steps)) with live children destroyed:  N3svt7IDLabelE (1.) N3svt10HyperLabelE (Select database) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Set up JDBC connection) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Set up user authentication) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Save and proceed) N3svt7IDLabelE (4.) N3svt10HyperLabelE (...) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Set up dBASE connection) N3svt7IDLabelE (3.) N3svt10HyperLabelE (Save and proceed) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Save and proceed)
Window ( N3svt8ORoadmapE (Steps)) with live children destroyed:  N3svt7IDLabelE (1.) N3svt10HyperLabelE (Select database) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Set up JDBC connection) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Set up user authentication) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Save and proceed) N3svt7IDLabelE (4.) N3svt10HyperLabelE (...) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Set up dBASE connection) N3svt7IDLabelE (3.) N3svt10HyperLabelE (Save and proceed) N3svt7IDLabelE (2.) N3svt10HyperLabelE (Save and proceed)
Comment 5 Michael Meeks 2015-05-08 16:30:08 UTC
Judging from the trace, prolly a dup - thanks for reporting ! =)

*** This bug has been marked as a duplicate of bug 91157 ***