Bug Hunting Session
Bug 91153 - FILESAVE : Empty hidden row export to xlsx does not remain hidden
Summary: FILESAVE : Empty hidden row export to xlsx does not remain hidden
Status: RESOLVED DUPLICATE of bug 98106
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Priyanka Gaikwad
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-08 05:49 UTC by Priyanka Gaikwad
Modified: 2016-06-20 13:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Original file (8.26 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-05-08 05:49 UTC, Priyanka Gaikwad
Details
Roundtrip file (6.43 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-05-08 05:49 UTC, Priyanka Gaikwad
Details
Comparison between Original and Roundtrip file (106.77 KB, image/png)
2015-05-08 05:51 UTC, Priyanka Gaikwad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Priyanka Gaikwad 2015-05-08 05:49:20 UTC
Created attachment 115441 [details]
Original file

Steps to reproduce:
1. Open attached file "test.xlsx"
2. save the file .xlsx
3. Open it again in excel

Current behavior:
The cell 2 and 3 are visible

Expected behavior:
The cell 2 and 3 should be hidden

If the row is empty and it is hidden then that row does not export right with hidden property.
Comment 1 Priyanka Gaikwad 2015-05-08 05:49:53 UTC
Created attachment 115442 [details]
Roundtrip file
Comment 2 Priyanka Gaikwad 2015-05-08 05:51:07 UTC
Created attachment 115443 [details]
Comparison between Original and Roundtrip file
Comment 3 A (Andy) 2015-05-09 07:55:41 UTC
Reproducible with LO 4.4.2.2, Win 8.1
Comment 4 Timur 2015-05-11 09:03:07 UTC
Reproducible already from LO 3.3.0.4. 
Not inherited from OO, since OO couldn't save as xlsx.
Comment 5 Xisco Faulí 2015-08-24 15:34:51 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 6 Katarina Behrens (CIB) 2016-06-20 13:35:08 UTC

*** This bug has been marked as a duplicate of bug 98106 ***